POSTGRESQL 9.51 (using Password) Backup Job stalls


#1

Scheduled or run now job sits at “The maximum file size” (log file below)
Noticed the following behaviour:
command line output sent to pg_dump --no-password (but the database does have password??)
In task manager pg_dump only one write to disk??
After stopping SQLBackupAndFTP service, pg_dump starts backing up the database to the temp folder

I have tried creating pgpass file but same issue.
Any help would be appreciated.

15/03/2019 13:07:35|Info|Starting job “DB backup” - “Full”. Computer “WWDB”. App v."12.2.1"
15/03/2019 13:07:37|Info|Connecting to PostgreSQL Server: PostgreSQL 9.5.1, compiled by Visual C++ build 1800, 64-bit. WWDB
15/03/2019 13:07:37|Info|The backup folder “D:\Temp\Pranas.NET\SQLBackupAndFTP\backup” has “83.789GB” free space. The temporary folder “D:\Temp\Pranas.NET\SQLBackupAndFTP\backup” has “83.789GB” free space
15/03/2019 13:07:37|Info|Backing up “WWDB” databases with pg_dump.exe: pg_dump (PostgreSQL) 9.5.1
15/03/2019 13:07:38|Debug|Getting maximum file size…
15/03/2019 13:07:38|Debug|The maximum file size: ""
15/03/2019 18:25:06|Debug|Cancelling job "DB backup "

Thanks

Nivag


#2

Hello Gavin_Ashton,

Thank you for the details, please give us some time to check this issue.

Sorry for the inconvenience.


#3

Hello Gavin_Ashton,

We have added some changes to SQLBackupAndFTP Alpha version https://sqlbackupandftp.com/download/alpha

If you choose the option to pass the password through a file (In Password File), then SQLBakcupAndFTP will transfer the password through the pgpass.conf file. The software will add this file itself.

But if you want to specify the password in the file manually, then please mark the file as ReadOnly so that SQLBackupAndFTP does not overwrite the data. Note that by default, a backup job runs on behalf of the local system user. The pgpass.conf file for that user is located at: \Windows\system32\config\systemprofile\AppData\Roaming\postgresql\