Not possible to add several MySQL-instanses to same db-server

Hello,

I’m running version 12.2.1 and the issue is that it is not possible to add several MySQL instances to the same MySQL server. As for example:

New backup job 1:
Hostname: testdb
MySQL port: 3321
Username: test
Password: test

New backup job 2:
Hostname: testdb
MySQL port: 3322
Username: test
Password: test

Both backup jobs will get the port of the last saved job,that is the issue, i.e. both job 1 and 2 will get the same portnumber in this case 3322 if backup job 2 was after backup job 1.

Best regards,
Magnus

Hi Magnus,

If you need to connect to your MySQL Server to backup databases with different credentials or with different ports then please specify Server name like:

localhost /* any description of the connection */
localhost /* connection for the second user */
localhost /* any other connection */

and use different credentials or ports.

If you have any additional questions, please feel free to contact us. Connect%20to%20MySQL%20Server

Thanks a lot Alexander!
It works fine now!

Best regards,
Magnus

Hi Magnus,

Good news! Please feel free to contact us on any issues or concerns.

Hi,

I’ve got the same question, but for PostgreSQL !

And it doesn’t seem to allow the “localhost /* any description of the connection /” syntax.

Regard,
Lionel

Hi Lionel,

Please make sure you have specified your server’s name like

localhost /* any description of the connection */

where:

localhost - is your server’s name
/* any description of the connection */ - any description to identify your server

Hi Alexander,

Your’re right, I did an error in the syntax.
It’s ok, thank you.

Good news! Thanks for the reply.

Please feel free to contact us on any issues or concerns.

Hitting this problem too. I’m running SqlBackupAndFTP on my local system, connecting to multiple remote servers (shared hosting servers where I can’t run the tool locally). In one case there are two databases to backup, with different connection parameters (username/password). If I set the username for one job, it also sets it for the other - there’s no way to get separate credentials for the two, and using Localhost isn’t an option as mentioned above.
The workaround I’ve found is to make sure the server names are different - so I refer to one connection by domain name, the other by IP address, and that seems to do the trick.

The problem I now have is that intermittently the connections fail with a message “Using a password on the command line interface can be insecure” (which is shown as a warning) followed by an error “Access denied”. The exact same connection definition works about one time in four…

Hi Derek_Pattenson,

With SQLBackupAndFTP you can connect to your MySQL Server to backup databases with different credentials or with different ports. You can find the wat how to do it in our reply above in this thread.

Thanks Alexander. Yes, as per my message, I’ve worked around by referring to the servers differently. The “password on the command line” problem remains, however. It seems the backup works for one database on the server, but NOT (ever) for the other. The connection settings are identical (apart from different subdomain name, username+password, and database name). This is a remote connection so storing the password in the environment doesn’t negate the need to pass it on the command line.

Hi Derek_Pattenson,

Could you please let us know, have you tried to connect to your DBMS using the suggestions above? For example:

localhost / any description of the connection /

where:

localhost - is your server’s name
/ any description of the connection / - any description to identify your server

Note, it works both with local and remote connections.