"Unexpected job type" error when viewing logs

SQLBackupandFTP has been running great now for years, non-stop without issues.
First off, thanks for the fantastic software.

That is until last Friday 3/18 when we noticed a new bug or issue.
When manual backups are run, or when existing Job History is viewed, we receive a pop-up dialog box with the following error, “Unexpected job type. Parameter name: JobType Actual value was unknown.” When we click OK, the error message disappears and the logs for that job are displayed just fine. This doesn’t appear to have any negative effect on our backup jobs - they are completing just fine.

This may have started happening after a recent auto-update.
On the 18th, SQLBackupandFTP updated to, and then yesterday updated to
I tried running the update from the software moments ago but it times out during the download at the very end.

I figured I would bring this error to your attention. I’m not sure if it is related to a recent software update or a known issue that you can assist with.

Thanks again,

Same here… I am getting this exact error after updating to 12.5.2. I’ve been using SQLBackupandFTP for years and haven’t changed anything. I’m guessing this is a bug in the update. If I hit “Run Now” to bypass my schedule times, or try to view a log, I get this same error.



Same issue here. Everything stopped working after March 17th. All of our installations are completely dead in the water. I noticed we are on version 12.5.2 as well. There error we get is “Failed to restore database. Value cannot be null. Parameter name: folder” This happens with all restorations which has never happened before. Will try to revert to an older version as we need to get backups resolved asap. I didn’t realize I had auto updates on which I will now turn off. Thanks.

Hello again. I resolved my issue. Something changed with the 12.5.2 update where I now have to add a / in front of my FTP folder path. That was not necessary in previous versions. Now I am able to restore without issue. Thanks.

Hello guys,

Thank you for getting in touch with us.

Please give us some time to check and fix this issue. We’ll keep you updated.

Sorry for the inconvenience.


Thank you for your waiting.

We have fixed the issue in the Alpha edition https://sqlbackupandftp.com/download/alpha

Could you please install it and check if it works for you?

Sorry for the inconvenience.