Unable to restore MySQL backup

I am trying to restore a MySQL backup to my online database.

  • When I use the MySQL server (PHPMyAdmin) connection I get the error:
    [Error] Failed to restore the database. The ‘img’ start tag on line 9 position 162 does not match the end tag of ‘a’. Line 9, position 254.

  • When I use MySQL Server (TCP/IP) I get the error;
    [Error] Failed to restore the database: [Warning] Using a password on the command line interface can be insecure.
    ERROR 1227 (42000) at line 2: Access denied; you need (at least one of) the SUPER privilege(s) for this operation

Hi Sary_Zainoun,

The error message you get is generated by MySQL, and it cannot be resolved from our side. We recommend you find more details on how to resolve it on the web.

Also, could you please try to restore that backup manually to check if you get the same error message?

Sorry for the inconvenience.

Hi Alexander,

Thank you for your reply.

I figured out the problem and fixed it, I will leave my solution here for others.

The problem appeared when restoring the procedures and views from my backup file, I knew that when I tried to restore a backup file without any procedures and views and it worked.

I changed the definer for the procedures and views in my local database to match the user name on my online database, and this fixed the problem.

Thank you again.

Hi Sary_Zainoun,

Thank you for the details. We appreciate it.

Thank you for using SQLBackupAndFTP.

1 Like

In Database Explorer, right-click the server connection on which you want to restore the database and select Backup and Restore > Restore Database. In the Database Restore Wizard, select the backup file and click Restore.

Hi Jameswalter,

Thank you for the information!