Unable to backup a PDM_Vault database as it is claiming it can't drop a snapshot database that is created for backing up

Failed to backup ‘PDM_Vault’ database with ‘Full’ backup type: Cannot drop the database ‘SQLBackupAndFTP_PDM_VAULT_SNAPSHOT’, because it does not exist or you do not have permission."

Up until a month ago, I was able to backup my PDM_Vault database residing on a MS SQL Server Express 2014 database with just a warning stating:

For an export to be transactionally consistent, you must ensure either that no write activity is occurring during the export, or that you are exporting from a snapshot of your database. Turn on “Create database snapshot for backup” option at Backup options section for export to be transactionally consistent.

But it was backing up. I would get daily reports on how it was doing and I was happy with the results.

Then it started throwing this error and I haven’t been able to fix it. Is there a permission I should grant the user it is using in order to be able to backup the database again?


Thank you for the details.

Could you please go to the “Backup options” and make sure that “Create database snapshot for backup (for export to be transactionally consistent)” option is disabled.


Sorry for the inconvenience.

When I remove the Create database snapshot option I get the error below:

I even tried using the sa account to see if it was just a permissions issue, but i still get that error with sa.

Hi Minesense_Technologi,

Could you please make sure that you use SQLBackupAndFTP version 12.3.10? If you have the same issue with that edition, please try to perform scripting manually via SQL Server Management Studio (SSMS) and check if you get the same error message?

Sorry for the inconvenience.

Today I upgraded from 12.3.8 to 12.3.10 and still get the same error unfortunately.

If i use the Tasks > Backup option in MS SSMS it backs up fine. If you meant to use the Generate script that errors out at the very beginning with no error to look up.

Hi Minesense_Technologi,

Could you please clarify, if it works when you generate script “Task” > “Generate script”?

Sorry for the inconvenience.