Unable to authenticate local server with windows authentication

Have only started looking at this today, but can’t for the life of me figure out how to authenticate properly with my local SQL instance. I have put the server name in the same as it is in SSMS, selected windows authentication, and entered my username in the domain\username format (for currently logged in user), and entered my password.

When I try and test connection, it just spins and spins, seemingly doing nothing. If I enter an incorrect password or username, it fails instantly, so it knows its the right details.

Eventually, after ages of spinning or ages of trying to load databases under select database, it produces this error in the logs:

A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 50 - Local Database Runtime error occurred. Cannot create an automatic instance. See the Windows Application event log for error details.

Windows event viewer is spammed with this error:

Windows API call OpenProcessToken returned error code: 5. Windows system error message is: Access is denied.
Reported at line: 1559. 

Hi Matthew_Parker,

To resolve the issue we need more details. Could you please, enable the Advanced log with the “Trace” level, reproduce the issue, and send logs to our dev team. Here are more details on how to do it How to send Log to developers | SQLBackupAndFTP's blog

Note! With the “Trace” level, a log can contain your passwords. Before sending a log to dev team please open it using any text editor and remove the information you prefer to keep in secret. You can find them by clicking the “Open folder” link at the “Advanced Log” window (“Tools” > “Advanced Log…”).

To make your logs private, please send them to: support@sqlbackupandftp.com

If you have any other questions, please let us know.

Sorry for the inconvenience.