Trying to connect sql server and get message "object reference not set to an instance of an object"

i had old version of sqlserverandbackup
and now when i upgrade it i get this massage after auto backup has failed
object reference not set to an instance of an object
what to do?


To investigate this case we need more information, could you please send us the Advanced Log? You can find a short tutorial on how to do it at

Sorry for the inconvenience.

thank you for your answer
i did it
waiting for sulotion

Thank you for the log files, we have checked them.

This issue is on our side and we’ll fix it.

Currently, we can recommend you to reinstall the application. During the uninstallation please remove all jobs configurations and do not export your previous jobs. But in this case, all your backup jobs and settings will be lost.

Sorry for the inconvenience.

thanks from ahead
btw is there anyway to get fail\success mail to 2 mail adresses?


Good news! Thank you for the feedback.

You can add multiple email addresses separated by a comma at the “Send confirmation” section.

Hi, this issue also happens in the 11.4.2 Version, should I do the same thing?

Hi there! I’ve encountered the same error, and have tried the suggestions. Please see attachment. Any assistance is worth the instance

SQLBackupAndFTP - 11.4.2 Free

Object reference not set to an instance of an object.


sending log to developers:

Unrecognized Guid format.


Same problem here
2018-02-08 11:19:27.5405|ERROR|45|Pranas.NET.SqlBak.Job.Sql.Impl.DatabaseHandler|GetDatabaseState|System.NullReferenceException: Object reference not set to an instance of an object.

Hello all,

I have just downloaded and installed v11.4.2 and getting the error “Object reference not set to an instance of an object” at first open of the application.

I was able to connect to the SQL Server, but the same error reoccurs and as such apparently unable to use the application.

Any updates on this issue?


Thank you for the details

We have just released SQLBackupAndFTP version 11.4.3 with the fix of this issue. You can download it at “Download” page or click “Help” > “Check for Update…” in your SQLBackupAndFTP.

Sorry for the inconvenience.

1 Like


Installed 11.4.4 and was able to successfully complete the process. Thanks for the update.

Good news! Thank you for the feedback.

Please feel free to contact us on any issues or concerns.