There is no destination to keep full database backup type

Hi, from one day to the next, the backup is not working anymore. No changes were made. The path for the backup is the same as before and as well there is enough space for the backup.

This is the error I get:
27.01.2019 12:13 Failed to backup “xxx” database with “Full” backup type: [JOB-BAK:1301#1] Failed to backup “xxx” database. There is no destination selected to keep Full database backup type.

Any suggestion that helps me?

Thank you very much in advance

Is the destination local or over the network? Over the network might show an issue at the time of the backup, even if just an overzealous power saving mode putting a NIC to sleep (I’ve seen patched drivers and assistants/PHBs turn that on)
Is the space more than enough for twice the uncompressed backup? if not and/or for non-local destinations, putting a temporary folder assignment where there is enough space locally for that might make a difference.
Possibly the destination could use a chkdsk and even a defragment to make sure those processes don’t see issues and to clear many that don’t otherwise show up. Best done after a cleanup run of temp files and such.
Knowing more about your setup would help us provide better targeted help. Things like how SLQBackupAndFTP is related to/connect to the Which type of *SQL database and where the destination is. Size of a full back in relation ship to the space available also helps (<10% of the size available or it over 20% or 50%?) Operating systems w/ versions and check that SLQBackupAndFTP is running the current version.

Adventuring in the Chaos that is IT, and related, in Toronto, Canada

Ok I can give more information, and what I already tried:

The destination ist local on the same machine. I changed the temp path and the storage path to a destination on the same machine with plenty of space, I get the same error.
The destination for the temporary folder is a SSD, so I think defragment it is not necessary. Anyway I did a chkdsk and tried to defragment, without any Result.

My setup is
Windows 10
MS SQL Server Express 2014
SQLBackupAndFTP Version is 12.2.1
The destination for storage and SQL-Server is on the same machine
The size of a backup uncompressed is 2 GB, compressed in .zip 1,74 GB
The free space available is 67 GB or 1,3 TB on the other hard disk I tried

I just found out on 24th January there was a new release from sqlbackupandftp installed. Since that day it is not working anymore.
I couldn’t find the release history with versions, details and rlease dates, but on my machine it says the last change on the software was 24th January.
Where do I get the previous version, and which version was that?

Thanks for help. If any more Information is needed for advice I’ll try to provide it.

I’m having exactly the same problem. Any help would be appreciated.

After switching back to 12.0.4 it is working again.
Autoupdate must be disabled after installation.

Seems to be a bug in the version 12.2.1

Hi Frank,

This error message:

means that you have to select a destination for your full backups. Please go to your destination settings and make sure you have checked off “Full” at the advanced settings.

Thanks for the tip about the full check mark.

This was checked and I still had the issue. But it was enough hint to my problem.

I had also checked the Emergency destination - used only if other have failed.
After unchecking this I am now able to backup again. Small bug with no hint. after 4 days of manual backups we are in auto again.


Hi Michael_O_Brien,

Good news, thanks for the information.

Please feel free to contact us on any issues or concerns.

Could you help, l did this exactly but am still getting the same error sir

Hi ramsy_rama,

Could you please send us a screenshot of your backup destination settings and the error message you get?

Sorry for the inconvenience.

Attached are the screenshots sir that explain more about the errors.
here is the web log

Attached are the screenshots sir that explain more about the errors.
My configuration.

Attached are the screenshots sir that explain more about the errors.
Errors displayed.

Hi ramsy_rama,

Appreciate your response with the detailed information!

To resolve the issue, please allow storing full backups to your destination place.

If the is anything else we can help you with, please let us know.