The database compatibility level '12' is not within the supported range of 80 to 130


With the last Azure SQL Database I have created, I got this issue when trying to backup the database:
ERROR: Failed to backup “xxx” database with “Full” backup type: The database compatibility level ‘12’ is not within the supported range of 80 to 130.

So I tried to update database compatibility level :

Now database appears with compatibility level 130 but I always get the same error message in SQLBackupAndFTP.

Is there a way to get rid ot this ?



Hello Paul,

Thank you for the issue reporting. Please give us some time to investigate it.

I’m facing the same issue. Has this been solved?
I’m using ver 11.3.4



This issue will be solved when SQLBackupAndFTP will be migrated to .Net Framework version 4.6, currently we are working on it.

Sorry for the inconvenience.

I just bought the license, could I have access to a previous version in the meantime?

When do you expect to have the version when it will be supported?


I’m getting the same error with 11.3.5
Any idea when will the fix be deployed?

Could you please tell us why do you need to have an access to a previous version? It would have the same issue.
Currently we are working to solve this issue, sorry but we do not have any specific release date.

I’ve just discovered the same issue.

Alexander, please consider this as a high priority.

We are still working to solve this issue.

Sorry for the inconvenience.


We have released SQLBaсkupAndFTP version 11.4.0. Could you please update to the latest version and check if the issue is resolved? You can do it by clicking “Help” > “Check for update…”

Sorry for the inconvenience.