Suspected Bug in Version 12.2.10

Hi, we are experiencing an issue with the latest version when trying to schedule local backups on a couple of our servers.

Repro Steps

  1. Install latest version 12.2.10 on clean Windows server 2019 on machineA
  2. Setup a local backup of ms sql express to a machine on our network
    eg machine1\sqlexpress
  3. Test connection and view databases (all fine)
  4. Setup a second backup job to another sql instance on another machine
    eg machine2\sqlexpress
  5. Test connection (ok) and view tables

This is where we are encountering our issue, when we view the tables it is showing the local databases on the machineA and not machine2 as per the connection string. It seems to work ok for the first backup job we add but any subsequent job we add this happens. It works fine if we select remote but this is not what we want.

It is very unusual behaviour we have tried on another machine on our network and the issue persists with this version.

I have tried the older version on your site 11.3.12 and it works perfectly on this version. Can you please advise how we can get this working on latest version, as 11.3.12 is missing some of the new features we would like to avail of.


Hi Jennifer_Russell,

Thank you for the details.

We have added some changes to the Alpha edition that should resolve the issue. Could you please download install and test it?

Please let us know if you have any issues with the Alpha edition.

Sorry for the inconvenience.

Hi, it has fixed the issue but we are getting a license error now

ERROR: Job execution error: Your license is valid for SQLBackupAndFTP version 12.2.10 or lower. Please upgrade your license or install suitable version. (

Hi Jennifer_Russell,

Thank you for your reply.

It was an issue on our side, which we fixed in the Alpha edition. Could you please install it and check?

Sorry for the inconvenience.