Severe Error on DiffBackup with Altaro Software

We use SQLBackupAndFTP for FullBackup once a day + Diff-Backups every 30 Minutes.
2 Times a day “Altaro” VM-Backup is performing and backing up the full SQL-VM (HyperV).

After Altaro was locking the MS-SQL-Server DB and copying it, the DIFF-Backup of SQLBackupAndFTP is doing only a Diff since the Altaro-Copy. But Altaro is NOT creating a .BAK File, but a .MDB File.
So it is not possible to perform a RESTORE with a Diff, because there is no correspoding .BAK.

This is a severe security problem as the last point of restore is the time of Altaro Backup.
So we lost the complete Data of 6 hours of working on the DB.

Why is the “copy” of the MDB of Altaro setting back the DIFF to 0 ?
Why is SQLBackupAndFTP not realizing that the last “full backup” was not performed by SQLBackupAndFTP ?

This is not to blame SQLBackupAndFTP but at least a restore with SQLBackupAndFTP is not possible even if everything worked fine with no errors.

Attached a hardcopy which shows the broken Diff-Sequence.

Hi Michael_Hinterauer,

When you use two backup tools your backup chain breaks. Please find more details about it at

Also, you can find more details on how to resolve it via SQLBackupAndFTP at Solved: [JOB-BAK:2006#11008] Previous Full backup of a database was created with a different application | SQLBackupAndFTP's blog