Service will not start

Hi. I am running 11.2.1 on a Windows 2012R2 server. We continue to fight with issues with the service not starting after a reboot. Updates continue to ignore the fact that I set the service to delayed start. Generally after forcing a start a few times, the service will start but this seems to be a continuing bug in the app and is problematic if we apply updates and forget to check the status of the service. We get the standard “A timeout was reached (30000 milliseconds) while waiting for the SQLBackupAndFTP (SQL Server backup) service to connect.”

1 Like

Having the exact same issue on server reboots!!!
I do NOT have delayed start enabled.

Additionally, no email is being sent about the failed back up. If the back up service is responsible for sending emails, it likely should not be so that we can still get notified of a failure.

One of the issues that I have reported before is that updates to the app reset delayed start, so even if you go that route, be careful you check the setting after applying an update.

Thank you for the issue reporting. We’ll check and fix this issue.

Also, SQLBackupAndFTP (SQL Server backup) Windows Service can be blocked by antivirus or any other security software.

If it is blocked by A/V or similar software, then why does it start later (manually)? This seems to be a recurring issue with various responses saying that it is fixed in various versions.

It is interesting that if I run services.msc and select start on the service, that it seems to start quickly, but when starting from the SQL Backup application it will often take multiple tries before it will start.

Could you please open your Windows Event Log and check are there any error messages added when SQLBackupAndFTP (SQL Server backup) Windows Service hasn’t been started?

It’s very rare issue and we are working to improve SQLBackupAndFTP (SQL Server backup) Windows Service work.

Sorry for the inconvenience.

I have exactly same problem

Was on 11.1.xx, switched to 11.3.9. Did not help.

The service just plain doesn’t start. No logs, no event logs (except "A timeout was reached (30000 milliseconds) while waiting for the SQLBackupAndFTP (SQL Server backup) service to connect.)

Great. You pay for product, they give you 1 month of support and after 2 months it simply stops working.

P.S. Windoows Server 2016

I have generally found that if I force a start in services.msc, after booting, that the service will start (and generally pretty quickly). I have had some luck with marking the service as delayed start, but every new update decides that it will reset my preference (I have reported this). It’s just a drag that something that you just need to work 100% of the time (backup software) is so fragile.

The biggest issue, is that, say you apply updates to your server, and reboot and presume that everything is good and the SQL Backup service never starts. You’ll never be alerted to job fails so you may go days/weeks without backups and never think, “hmmm, I haven’t seen backup e-mails in quite a while.” Just now, I loaded up the UI and got the dialog about the service not being started, so you request a start and it fails. So I went over to services.msc and clicked start and it started right up. Seems like this should not be rocket science to fix.

Thank you for the details.

You might need to provide permission using the below instruction.

  1. Click Start > Run > Type > dcomcnfg, expand Component Services > Computers > My Computer > DCOM Config.
  2. Click View > Detail -> Now you will get Application Name and Application ID in right side.
  3. Scroll down and find the application ID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} > Right Click > Properties and select the Security tab.
  4. Click Customize under “Launch & Activation Permission” > click Edit > Add in the account serverName\UserName and set local launch and local activation.
  5. Restart the application Service linked to this Application ID or restart the server and monitor