Script Transfer Failed with multiple back-up jobs


We’re using your application to back-up multiple database servers who are not connected to a domain. The jobs are starting fine now, but some of them are returning an error with the message: “Script Transfer Failed”.

Below the complete log with the names hidden:

Summary (Failed)

Date: 5/5/2021 1:31:43 AM
Backup type: Full
Backup archive size: 0B
Database backup: failed
Next backup: 5/6/2021 1:31:00 AM - Full

Detailed Log:
•1:31:43 AM : Starting scheduled job “” - “Full”. Server “”. Account “<Local “System Account>. App v.“12.5.5”.
•1:31:45 AM : Connecting to: 2008 R2 RTM Express Edition with Advanced Services (64-bit).
•1:31:46 AM : The backup folder “C:\Windows\TEMP\SYSTEM\Pranas.NET\SBF\44315a8e-a267-4a77-9bbe-c326035568c3\backup” has “38,027GB” free space. The temporary folder “C:\Windows\TEMP\SYSTEM\Pranas.NET\SBF\44315a8e-a267-4a77-9bbe-c326035568c3” has “38,027GB” free space.
•1:31:46 AM : Backing up “” Remote SQL Server databases.
•1:31:46 AM : Backing up “<“Database Name> database to .sql file.
•1:37:26 AM : ERROR: Failed to backup “<“Database Name> database with “Full” backup type: One or more errors occurred. > Script transfer failed.
•1:37:27 AM : Cleaning up backups of “” job.
•1:37:29 AM : ERROR: Job “” finished with “1” errors.

What can we do to solve this?

Thank you in advance!

Hi Lancom,

During script generation, we use official libraries, and the error message you get is generated by these libraries. Sorry, but that issue cannot be resolved from our side. If you run scripting via SSMS you’ll get the same result.

To resolve the issue, please install SQLBackupAndFTP on the same server where SQL Server is installed and use the local connection.

Thank you.

thanks for the awesome information.

Hi Jacky_Joy,

No problem, please feel free to contact us on any issues or concerns.

Hi, I got the same error, but i cannot install the program on the same server because there are more than one. Is it there another solution? the error suggest it is a problem of transfering the script. Is it possible to have more details ? maybe i just misconfigured something somehow.

Hi Cdlan_Systems,

We have checked the issue and can confirm that everything works smoothly on our side. Sorry, but that issue can’t be resolved via SQLBackupAndFTP. Could you please contact your DBA to check it or please try to find more details on the web.

If you have any either questions, please let us know.

Thank you and sorry for the inconvenience.


I face this issue today and befor it runing without any problem.
Error :Failed to backup “_______” database with “Full” backup type: One or more errors occurred. > Script transfer failed

Hello Mustafa_Mohammad_Saw,

“Script transfer failed” is a common error returned by the official library for SQL Server operations. There can be numerous reasons behind this error, ranging from network issues to errors in generating SQL code for backup.

This error cannot be resolved from our end; all we can do is regularly update these libraries. We can confirm that all libraries receive regular updates.

The only recommendation we can offer is to try scripting through SSMS to pinpoint the issue. You can find instructions on how to do this online or reach out to your DBA for assistance.

If you have any further questions, please feel free to let us know.

Thank you for using SQLBackupAndFTP.