S3 Compatible Slowed Down

I have an upload going to Wasabi Using the S3 compatible option. Since I started using it it has taken about 3 hours to upload 85 GB (100Mb connection). Starting 2/17, it now takes 12 hours. I noticed that the version of the software is 12.4.16 but I can’t tell when it updated. No other changes were made and my other system sending data to Wasabi is not having the same issue. Am I alone on this?

Also, for the Wasabi S3 option, it doesn’t work. I think you need to remove the hard coded URL and allow or the URL based on region.

Hi Russ_Gonring,

Could you please try to set S3 Compatible Custom with your region and check if the speed increases?

Sorry for the inconvenience.