Restore Failed With Drop Failed For DataBase

I was making Restore job and I chose Local/NetWork/Nas as source which has databases that were backed up by backup job from remote server to local drive
i chose one database and took last one as database to restore
Then i chose restore to remote sql server as restore destenation and i configured the connection and it was tested successfully
but when i run restore job i got the error
Failed to restore MyDataBaseName database. Kill database failed for Server ‘ServerName’. > Drop failed for Database ‘MyDataBaseName’. > An exception occurred while executing a Transact-SQL statement or batch. > Cannot drop the database ‘MyDataBaseName’, because it does not exist or you do not have permission.

i created this database on remote server in order to restore data to and in the back up job I configured the following advanced settings

my question is why backup operation fails because of trying to drop or create desired database even though in more settings of backup job i have never chose to back up DataBase Definition ,and back up generated script didn’t contain any create database or drop statements

Hi William,

Currently, we are working to improve our restore job, where that issue will be fixed. Once the Alpha edition will be ready we’ll send it to you.

Sorry for the inconvenience.

Hi William,

Thank you for waiting.

We have added some changes to the Alpha edition that should resolve the issue. Could you please install it and check if it works for you?

Sorry for the inconvenience.

i installed new alpha version but still having same error even though iam trying with database user that has read and write permissions to any database

also iam facing a new problem when pressing Restore options i get Access is denied
can i have a help in restoring issue please

Hi William_Mutraji,

To investigate this case we need more details. Could you please provide us with the Advanced Log?

Please notify us when the log will be sent.

Sorry for the inconvenience.

i didn’t find away to upload the log except as an image

is there any other way that i didn’t realize ,upload doesn’t accept txt extension which is exported from log

Hi William_Mutraji,

You can send the Advanced log using the instructions in the blog post. We attached the link in the previous reply.

Also, please make sure you use the latest version of the application Download SQLBackupAndFTP - SQL Server Backup Software

Please let us know when the log will be sent.

Thank you!

i cant send log to developers because iam getting an exception in sending log as i have a lot of exceptions in this version which is Lite

i wasn’t able to post the exception as an image and i cant write it because it is so long and the policy here didn’t allow me to post another image for new users so iam not able to send the log or the exception of the log can you help me please ,can you give me an email to send to as an alternative

Hi William_Mutraji,

Sure, please send the details to

Sorry for the inconvenience.


During the restore process, SQLBackupAndFTP does not parse the file for a database definition or anything else. There are two reasons for this:

  1. A backup file can be very large - and its analysis will take the time and resources of the server on which the restore is performed.
  2. We do not generate SQL ourselves, but using official libraries for working with SQL Server. After the update, the generated SQL may change about which our self-written SQL analyzer will stumble upon.

A restoring process that is run via a restore job can work correctly only with the default settings of the advanced options of a remote backup specified in a backup job. Sorry, but we cannot change it due to the reasons stated above.

Sorry for the inconvenience.