Remote Backup Config shows wrong databases

Hi there,

I have a local copy of Mysql databases (6 of them in the one Mysql server) for development that I am already backing up fine (i.e the source is true localhost on a windows machine). That’s all fine.

I have now set up a 2nd backup job to backup the REMOTE production versions of some of those databases (only 3 in that MySQL instance on a Linux server). I have configured the job to use SSH to connect - see here:

Test connection is successful - but when I go to select the databases in the next step of the job setup it shows all the databases from the local MySQL instance. If it was looking in the right place it should only list/show 3 databases (not the 6 it’s showing). Just to confirm I ran the job and all 6 databases were backed up - which implies it’s ignoring my remote connection and backing up my local instance instead.

Am I missing something?


Hi Adam,

To resolve the issue, we require more details. Could you please enable advanced logging with the “Trace” level, reproduce the issue, and send the logs to our development team? You can find detailed instructions on how to do this here: How to send Log to developers | SQLBackupAndFTP's blog

Please note that with the “Trace” level, logs may contain your passwords. Before sending the logs to the development team, please open them using any text editor and remove any sensitive information. You can locate them by clicking the “Open folder” link in the “Advanced Log” window (accessible via “Tools” > “Advanced Log…”).

Once the logs have been sent, please notify us and provide your App ID (“Help” > “About”).

Please inform us when the logs have been sent.

We apologize for any inconvenience caused.

Hi there - thanks for that - I have done as requested via a support ticket instead - so you can ignore this forum version.


Hello Adam_Helman,

We are posting this here in case other users encounter the same issue.

To resolve the issue, please navigate to the connection settings and in the SSH Tunnel section, try specifying a different local mapped port. For example, instead of using 3306, try using 3300.

If you have any other questions, please don’t hesitate to ask.

Thank you, and apologies for any inconvenience.

1 Like