Postgres Backup Fails Error Code: 1073741515 (solved)

I am backing up a postgres db since a couple months and I am very happy. I tried to move SQLBackupAndFTP to a different PC, I configured everything exactly the same but the backup job did not work at all and always crashed with the error code: 1073741515. Connection Tests to the db did always work

When I tried to start the pg_dump.exe manally it said that zlib1.dll is missing. I copied this file from my working computer to the new one and everything worked. I installed SQLBackupAndFTP on several Computers and I always got the same message, to me it seems that the file is not created during the program installation.

Please look into this, because downloading dll files from the internet is usually not a good idea…

I am testing on the latest version of win10 and SQLBackupAndFTP


Hi Lukas_Eggenschwiler,

Yes, we have this issue in the release, but it is fixed in the Alpha edition. You can download it at or you can specify the path to your bin folder at the Advanced settings at the connection window.


Sorry for the inconvenience.