Operating system error 3(The system cannot find the path specified.)

Sooner or later, working with SQLBackupAndFTP you can get the following error message

27/11/2016 15:19:51 Creating backup of data_newlevel
27/11/2016 15:19:52 ERROR: Backup of data_newlevel failed: Cannot open backup device ‘C:\Windows\TEMP\data_newlevel200910271519.bak’. Operating system error 3(The system cannot find the path specified.).
BACKUP DATABASE is terminating abnormally.

The Solution will be the next:

Please grant LOCAL SYSTEM (or LOCAL SERVICE) account with write/read permissions for C:\Windows\TEMP… folder or specify different temporary folder

Also, please make sure that you have enough free space on your drive.

I get this ERROR now after upgrade:
I tried this solution… still not working

9:29:14 AM : Starting job “new.jobx” with backup type “Full”. The computer name: “JAM88”. The application version: “11.1.5”
9:29:15 AM : The backup folder of the job is “D:\DB_DUMPS” with “298.863GB” free space. The temporary folder of the job is “C:\WINDOWS\TEMP\SYSTEM\Pranas.NET\SQLBackupAndFTP\backup” with “123.801GB” free space
9:29:15 AM : Backing up “” SQL Server databases
9:29:16 AM : Getting maximum file size…
9:29:16 AM : The maximum file size: “”
9:29:17 AM : Backing up “plums_bearM” database to .bak file. Backup type: “Full”. Checksum: “Disabled”
9:29:19 AM : “plums_bearM” database backup successfully completed. Backup type: “Full”
9:29:20 AM : ERROR: Failed to backup “plums_bearM” database with “Full” backup type: Could not find file ‘D:\DB_DUMPS\plums_bearM201708080929.bak’.

I checked permissions in folders., nothing helps. HELP!


Could you please make sure that the user from whom SQL Server runs has enough permissions to the following folder “DB_DUMPS”?

Hello I have the same issue, and I haven´t found the solution.

Someone have any idea?

Please find more details at the following blog post: https://sqlbackupandftp.com/blog/how-to-solve-operating-system-error-3