OneDrive for Business Restore fails

Restore of a Backup (using 7Zip with password on highest Compression) causes this error:

If I download and unzip the backup-file manually, I can restore the database.

Thank you for the issue reporting. We’ll check and fix it. Also, please tell us what version of SQLbackupAndFTP 11 do you use. You can find this information by clicking “Help” > “License…”.

Thank you for the clarification. We’ll fix this issue.

Restore of a Backup from OneDrive for Business (using 7Zip with password on highest Compression) still doesn’t work. It just doesn’t show an error/failed anymore. Keeps showing “Uncompressing” for ever…


Thank you for the issue reporting! We’ll fix it as soon as possible.


Hi Alexey
Thank you for your feedback.
I’m currently testing V11 on our development system while the production system still is on V10 and does backups on google-drive as well as on a ftp share.
I really would like to only use one-drive for business in future therefore I didn’t test V11 with google-drive and now the trial-licence on development expired. Can I somehow get another trial-period on the dev system as soon as my one-drive for business issue is solved? I really need to be sure it works before I migrate the prod…


We have just released SQLBackupAndFTP 11.1.10 with a fix for this issue.
You can start a new trial period if you uninstall and install the application again.