One-Click Restore and Restore Permissions Issues


I have two issues.


I have used an old version of backup and FTP for a number of years. The One-Click restore feature was incredible. Even when Microsoft management studio was problematic your restore just worked magically. This was my favorite and I literally use it everyday restoring and deploying databases. After installing the new version none of these features are now available. Is there a way of getting them back or should I look at downgrading back to the version I had from a number of years back.


I tried to come to terms with your new way of restoring databases. I think it’s not very time consuming unless there is a faster way? Open the software, navigate to the backup location, connect to the database server, select the database, then restore. By far not as good as the older version where all I had to do was click on the .bak file and then select the database to restore it. Anyway I tried to get your new way of restoring working but was encountering errors every time.

It sounds as though it is permissions error but I am not sure how. I opened your software as administrator and checked permissions on the file path. I never had any of these problems with the older version so kind of expected this new version to work magically like the the last one.

Any help would be much appreciated.

I dont really want to downgrade back to the old version since one of my clients wants to make sure of the One Drive backups and my old version only supports FTP. I think not having One-Click feature is a shop stopper for me. I kind of rely on that feature now. I was thinking would there be any way to get both versions working on the same server. So use the new version for the cloud storage backups and the existing version for its awesome One-Click restore features?

Thanks in advanced.

Kind Regards


Hi Guys,

To add I sorted of managed to get it to work.

  1. I have to give everyone read/write permissions on the .bak file. Really annoying that I will have to do that for every file. I suppose a work around could be to have backups stored in a folder with full permissions then when I want to restore a database I first copy it into that folder and start from there. (not ideal)

  2. Also I found another issue that I cant select the database to restore to. I have to manually type the database name in rather than selecting from a list in the old version.

I feel in terms of the restore features this is a massive step in the wrong direction. The old version was amazing. Hopefully I am just doing something totally wrong?

Kind Regards


Hi David_Armitage,

Thank you for your posts with the details.

The latest release of SQLBackupAndFTP creates backups (.*bak files) in the same way as the old versions did and in the same way as you do it via SQL Server Management Studio. It means that the backups (.*bak files) that were created via the latest release of SQLBackupAndFTP can be restored via the One-Click restore tool as well. But the easiest way to restore the backups is to click on the “Restore from Backup…” button from the “History & backup” section.

Please find more details at

If it is convenient for you, you can still use the One-Click Restore tool to restore the backups of your local SQL Server databases.

If you have any other questions, please let us know.

Thank you for using SQLBackupAndFTP.