MySQLServer connection with SSH tunnel: "The requested address ist not valid in its context"


I tried setting up a backup job (MySQL Server (TCP/IP) using SSH Tunnel - see screenshot), however I always get the error “Socket error 10049 occured. The requested address is not valid in its context.” when testing the connection or starting the backup.

Is there anything I’m doing wrong or is this a sqlbackupandftp issue?

Hi gesagt.getan,

Thanks for the details.

Sorry, but this issue isn’t related to SQLBackupAndFTP, it seems this error message related to your networks settings. Could you please contact your network administrator to check this issue. Also, you can find more details about that error message on the web.

Sorry for the inconvenience.

Experiencing the same 10049 socket error, but only when using SQL Backup and FTP. For example, when the same connection settings are used in MySQL Workbench on the same client machine, the connection is made just fine. What network settings are specific to SQL Backup and FTP that are causing this? Wondering if you can point me in the right direction for a fix. Thanks.

Hi Mike,

Sorry, but in SQLBackupAndFTP, when using SSH, the only localhost is valid at the “Server name” box. If you need a more complicated configuration, then please try to open the SSH tunnel with some third-party software.

Sorry for the inconvenience.

3 years later and still the same error?
This is a security feature in this day and age and I would expect such a professional software to have this feature implemented. running phpmysql on the website to make a backup is just too dangerous.

Hi purecrea_gmbh,

SQLBackupAndFTP has an option to open an SSH tunnel using Putty “Tools” > “Settings” > “SSH settings”.

Please let us know if you have any other questions.

Thank you for using SQLBabkupAndFTP.