MySQL (TCP/IP) "Full" backup type: - fails


I have just switched to SQLBackupAndFTP from MySQLBackupFTP and now I get the following errors by trying to backup a MySQL Server (TCP/IP)

Failed to backup “database name” database with “Full” backup type:

Is there anyone who can help find out why?

In advance thank you


Please, enable Advanced Log using main menu of the application: Tools -> Advanced Log… Then reproduce the issue and send us the advanced log using the same menu item.
Also, please tell us what is your application id. You can find it on About window: Help -> About.
Thank you!


Log hereby sendt :slight_smile:

Application id: 8cea4ce4-6e9a-4be9-be22-1318300b3027

Having the same issue after upgrading. Test Connection works with no errors.
When trying to backup get
1043 error: Bad Handshake when trying to connect
App ID: 183ae2dd-fdf1-45d0-9e4f-643f33ee653b

Advanced log has been sent through the application


Thanks for the details. Please try to resolve the issue using the following recommendations:

  1. Run the following command via Command Prompt:
    "C:\Program Files (x86)\SQLBackupAndFTP\DBMS\MySql\mysqldump.exe" --version
    and check if you get the same error message.

  2. Please check your Windows Event Log (Application and System) are there any error messages related to mysql\mysqldump.exe\SqlBackupAndFtp

  3. Could you please tell us do you use any software that is responsible for the security? If yes, please try to disable it for a while, for the test, or add SQLBackupAndFTP and C:\Program Files (x86)\SQLBackupAndFTP\DBMS\MySql\mysqldump.exe file to the exception list.

  4. Please try to install «Visual C++ Redistributable for Visual Studio 2015»

Sorry for the inconvenience.

I am currently backing up 2 MySQL DB’s. One works fine and one fails with the failed handshake error.
Result for 1.

Microsoft Windows [Version 10.0.17134.407]
© 2018 Microsoft Corporation. All rights reserved.

C:\Users\Lol>“C:\Program Files (x86)\SQLBackupAndFTP\DBMS\MySql\mysqldump.exe” --version
mysqldump Ver 8.0.12 for Win64 on x86_64 (MySQL Community Server - GPL)

Result for 2: Windows Event 1051
Just names the application that threw an error. Nothing useful

Result for 3:
Local Security software not an issue. As i mentioned only one of two DB’s is failing to backup.
So the software itself is working

Result 4
Vis Studio 2015 is already installed, as per answer 3, problem is only affecting 1 DB.

The DB that is failing is hosted on CentOS Server, running Plesk Server V12.5.3
MySQL Version 5.1.73


  1. Resulted in the following errors:
    “The program can’t start because VCRUNTIME140.dll is missing from your computer…”
    “The program can’t start because MSVCP140.dll is missing from your computer…”

  2. There was no error in Windows Event Log

  3. Nothing beyond what comes with windows

  4. That worked, which I also expected from the error in 1.

Thank you very much for helping

Can I add I am using a licensed version of the software so would appreciate a timely response. I am currently unable to automate backups for one of our most important clients databases


Could you please install the following release and specify the path to your original mysqldump at the “Advanced Settings” at the “Connection Settings” window. For example C:\Program Files\MySQL\MySQL Workbench 6.3

Please let us know if the issue is resolved.

Sorry for the inconvenience.

Settings changed after update and now getting a ERROR 1044 Access denied message.
I have re-entered the password to confirm the settings are correct

I am now also getting an ‘Access Denied’ error for the Database that was previously working fine.
It would appear this alpha release still needs some work.

From the logs It looks like the software is trying to connect to the local machine rather than the configured remote host.

Hi Lol_Moor,

Thanks for the details. Could you please send us your advanced logs again to check them? Please let us know when the logs will be sent.

Sorry for the inconvenience.

Replied via email and sent logs at 12:35 (GMT) Yesterday.


Thanks for the details, but we need more information to check this issue. Could you please execute the following command:

mysql --host <your ip mysql server> --port 3306 --user benridge_caresys --execute "SELECT VERSION();" --html mysql

and send the results to our dev team. To make them private, please send them to

Sorry for the inconvenience.

I found this post because I had the exact same issue after updating to the new combined SQLBackupandFTP application. Server 2012 R2 install originally had both separate apps installed.

The install itself worked great and correctly removed the old MySQL app. However all of my MySQL jobs now failed with the OP error message.

I ran the mysqldump.exe --version command line mentioned above and it threw an exception about the missing C++ library. Installing the C++ library immediately resolved that error and my backup job now runs without error. Didn’t even have to do a reboot.

Where do you want me to run this? From a cmd line targeted in C:\Program Files (x86)\SQLBackupAndFTP\dbms\mysql ?

If i run SELECT VERSION() through workbench it shows 5.1.73
If i try from the path above using mysql.exe supplied with you application it returns an ERROR 1045 as no password is supplied

I added switch to include password and user and have generated a response which I have emailed to you.

Any update on this?:weary:


Thank you for the details. Please give us some time to investigate this issue.

Sorry for the inconvenience.

Hi Lol Moor,

We have checked your logs and found the following error message:

ERROR 1044 (42000): Access denied for user xxxx to database ‘mysql’

That error message related to MySQL Server settings and cannot be resolved from our side. Please make sure you have specified the correct User Name and password at the connection window.

Sorry for the inconvenience.