JOBX file does not import

I just updated to V11 and imported a JOBX file which silently failed. No errors, but no configuration information was updated, no databases selected, no schedule, etc. I noticed that the GoogleDrive line in the JOBX file did not have any auth information, so I deleted that node in the XML and reimported the JOBX. This time, it imported OK. Seems like this is a bug. At least tell me what is wrong, better yet, prompt for authentication information.

I have the same issue. It’s not a complicated backup configuration either, but it refuses to import. No errors.

Thank you for the issue reporting. We’ll check and fix it as soon as possible.

Sorry for the inconvenience.


Google Drive, OneDrive and Box destinations have an authorization token with a time limit. That’s why your jobx file does not contain authorization data. An old version of SQLBackupAndFTP saves auth token and refresh token into other files and updates these tokens if it needed. In the other case, it would have needed to update the jobx file every time when it runs the backup job.
So, if you import a jobx file, you need to authorize the destinations with a temporary authorization token again.


That wasn’t the issue as the settings wouldn’t even show. I’ve updated to the latest v11 and the import issues have been resolved. It does need re-authenticating like you say, which is fine, but it wouldn’t even get to that point before.

Everything seems to be working fine, the only difference I see now is that there used to be a 7zip option to say that you want to split files into 100MB files. That’s gone in the new one. Is that because OneDrive etc doesn’t limit the upload size the same any more?

You can set up 7zip compression at the “Compression” section.

Any way to set the archive file size limit? So file sizes don’t go over 100MB?

SQLBackupAndFTP doesn’t have 100 MB limitation to upload to OneDrive.