Issue when backing up different mysql server on the same machine


I’m having an issue when backing up a different mysql database when also backing up another mysql database (different docker container) at the same time at the same server.

I have 2 mysql servers running on different containers, one on port 3306 and another on 13306, I cannot backup both of them at the same time for some reason.

I already tried backing one up through SSH tunnel, and another through direct IP, or both same IP but different port, always a similar error.

The username and password are different on both databases.

Is this intended?

The only thing that works right now is making sure that neither of them run at the same time, otherwise the most recent one is always failing.

Thank you

EDIT: SQLBackupAndFTP 12.7.22 running on Windows Server 2022.

Hello Karbust,

The error you are observing indicates that the socket (IP + Port) for the SSH tunnel that the application is trying to use is already in use. Ensure that the tunnels opened by the application use different Local Mapped Ports.

Also, could you please let us know, have you tried both through direct API? Is it also giving an error?

Additionally, as a workaround, consider scheduling backup jobs at different times.

Please let us know if you have any other questions.

Thank you for using SQLBackupAndFTP and sorry for the iconvenience.


I have both mysql servers running on the same remote server (using Docker), one on port 3306 and the other on port 13306.

What do you mean by direct API? The error is happening when I connect both directly to the IP address (via VPN tunnel (tested via Tailscale, ZeroTier and Wireguard)) and via SSH tunnel.


The screenshots is how they are currently configured, need to run each other separately so the backup on port 3306 doesn’t fail (it is the first to start).

Both are on the same server, running on different ports, and, as far as I know, the local mapped port is different.

Not exactly sure why it is happening.

Hello Karbust,

Thank you for the details.

To resolve the issue, please try using the plink option in the SSH settings section in the Settings window (“Tools” > “Settings” > “SSH Settings” > “plink”).

Please let us know if you have any other questions.

Thank you for using SQLBackupAndFTP, and sorry for the inconvenience.


With plink it can’t even connect to the database, but it is accessible. I have tried that before and went back because of that problem.

The configuration is the same.


The private key is in ppk format.

On the 25th, the backup failed for some reason, even though the backup job of the other database had finished more than 1 hour before it started, with the same error as my original post.

The other database’s backup job starts at 0:00, and this one starts at 2:00, the first one takes about 45min to complete.

Any other tips?

Hello Karbust,

We are afraid we may face challenges in resolving the SSH tunnel collision issue without direct access to your computer. It’s possible there might be a misconfiguration or an issue on your end. Troubleshooting such complexities requires thorough analysis, which is difficult to perform remotely.

Please try contacting your system and database administrator; they may be able to provide you with more details.

Thank you and sorry for the inconvenience.


I am the system and database administrator, however I cannot figure out the issue.

I use Navicat to navigate through the databases and I can access both of them at the same time through SSH tunnel on the same server and different ports, this must be something misconfigured on the application’s side

I will put this on the side for the future to try and solve as of right now I lack the available time needed.

Thank you

Got the same issue, solved it for now, I use one MYSQL database on port 3307 with NAS ipnummer , and one MYSQL database (docker container on same NAS, same IP) with DNS name (same NAS ipnummer) and portnumber 3322.

So, changed one ipnummer to DNS name

Hi E. Bakker,

Good news! Thank you for providing the solution.