Google Drive Backup Path

Backup by URL was running successfully.

When I tried again with the same URL, I failed.
My folder is Backup/

When I specify it this way, it creates a new folder.
How should I do?
Your support will make me very happy.

Hello Semih_Karalar,

Thank you for your patience.

Regarding the issue you’re experiencing, it is a known behavior described in detail at the bottom of this article: Update of SQLBackupAndFTP integration with Google Drive | SQLBackupAndFTP's blog.

“If a folder (or folder hierarchy) specified in the Google Drive destination settings was not created by the SQLBackupAndFTP application, then after reconnecting to Google Drive, a folder with the same name may appear. Newly created backups will be stored in this folder. Note that this is not an error, but rather a feature of Google Drive.
If this confuses you, navigate to the Google Drive destination settings within the backup job settings and specify a new, non-existent folder (path). It will be created automatically on your Google Drive.”

In your case, one duplicate folder will be created, which is due to the fact that we updated the integration with Google Drive. Google Drive will automatically create this new folder, and newly created backups will be stored there.

Please note that you will need to manually delete any backups that were created earlier in the original folder, as SQLBackupAndFTP have lost access to them.

Thank you and sorry for the inconvenience.