Ftp stop working after migration to new serwer

I’ve moved from Server 2012 to 2016. On 2012 everything worked perfectly.
After reinstaling to 2016 I can’t use ftp.
I can log to ftp via windows standard client - everything works (firewall is off).
With try ftp with application when I test ftp connection I have “Object reference not set to an instance of an object” (firewall is also off)
I use version 12.4.13 license standard


It turned out that ftp did not work when I pressed test button. It works when job is executing.
However sending email confirmation stop working… job finishes but there is the same error at the end of job summary concerning emails:
“26.02.2021 23:30:40 [Error] Can’t send email to … : Object reference not set to an instance of an object.”
The strange thing is that when I press test button to test sending email it works …

Hi Mirek,

Thank you for the details.

Sorry, but version 12.4.13 is old and no longer supported. Could you please install the latest release of SQLBackupAndFTP - version 12.4.16 and test if it works for you?

Sorry for the inconvenience.