FTP slow when sending DB

Goodmorning everyone,
I have a problem with the latest versions of the software. When I send the compressed DB to an FTP server, it does not exceed 50 KB/s of speed.
Also known is an unusual use of storage by the SBAF process.
For example, if I send to the FTP server through FileZilla, I use all the bandwidth in UP without any problems.

What am I doing wrong?

Thank you

Thank you for the issue reporting, please give us some time to check and fix it.

Ok thank you. Let me know if you need logs or FTP server features.

Sure, thank you. Sorry for the inconvenience.

13:13:01 : Starting scheduled job “backup.jobx” with backup type “Full”. The computer name: “SERVER”. The application version: “11.2.0”
13:13:02 : The backup folder of the job is “D:\MSSQL\Backup” with “351,714GB” free space. The temporary folder of the job is “C:\Users\user\AppData\Local\Temp\Pranas.NET\SQLBackupAndFTP\backup” with “68,627GB” free space
13:13:03 : Backing up “.\SQLEXPRESS” SQL Server databases
13:13:03 : Getting maximum file size…
13:13:03 : The maximum file size: “”
13:13:03 : Backing up “euro2000” database to .bak file. Backup type: “Full”. Checksum: “Disabled”
13:14:00 : “euro2000” database backup successfully completed. Backup type: “Full”
13:14:01 : Database “euro2000” has been successfully backed up to “euro2000201709221313.bak : 1,872GB”
13:14:01 : Compressing “euro2000201709221313.bak” file with Internal archiver. Encryption: “Off”
13:15:52 : Backup of “euro2000” has been successfully compressed to “(euro2000201709221313.zip : 178,108MB)”
13:15:53 : Connecting to Folder destination “D:\BACKUP_EURO”
13:15:53 : Reading folder information by path: “D:\BACKUP_EURO”
13:15:53 : The current folder of the destination is “D:\BACKUP_EURO”
13:15:54 : Sending backup of “euro2000” to Folder destination “D:\BACKUP_EURO”
13:15:54 : Uploading the local file “euro2000201709221313.zip” into a remote file “euro2000201709221313.zip”
13:15:57 : Uploaded 100 % (average speed = 63,7 MB/s)
13:15:59 : Verifying remote file “euro2000201709221313.zip” with local one “euro2000201709221313.zip”
13:16:01 : Connecting to FTP destination “silver.solidspace.org
13:16:01 : The current folder of the destination is “/”
13:16:02 : Sending backup of “euro2000” to FTP destination “domain.org
13:16:02 : Uploading the local file “euro2000201709221313.zip” into a remote file “euro2000201709221313.zip”
13:16:08 : Uploaded 100 % (average speed = 52,4 KB/s)
14:14:04 : Verifying remote file “euro2000201709221313.zip” with local one “euro2000201709221313.zip”
14:14:05 : Disconnecting from FTP destination “domain.org
14:14:05 : Cleaning up backups of “SQLeuro2000backup.jobx” job
14:14:05 : Cleaning up backups of “euro2000” database at Folder destination “D:\BACKUP_EURO”
14:14:06 : Cleaning up “D:\BACKUP_EURO” folder
14:14:06 : Deleting old backup of “euro2000”. Backup type: “Full”. Backup time: “09/15/2017 13:16:06”. Files: “euro2000201709151313.zip”
14:14:07 : Cleaning up backups of “euro2000” database at FTP destination “silver.solidspace.org
14:14:08 : Disconnecting from Folder destination “D:\BACKUP_EURO”
14:14:09 : Job “SQLeuro2000backup.jobx” finished


Currently, we are working to solve this issue and it will be fixed in the next release in 2-3 days.

Sorry for the inconvenience.

No problem, thanks and congratulations for your product.


We have released SQLBackupAndFTP version 11.2.1 where uploading speed to FTP destination place is increased.

You can update your current version to SQLBackupAndFTP version 11.2.1 by clicking “Help” > “Check for Update…”.

Sorry for the delay.

Now works at full upload speed. Thank you.

Good news! Please feel free to contact us on any issues or concerns.

Maybe there’s a problem with the speed indicated :slight_smile:

“average speed = 346,2 MB/s”

I’d like to have that connection, but I stop at 10 Mbit in upload.

For the rest everything works great :wink:


This issue will be fixed in the next release - SQLBackupAndFTP version 11.2.2. We plan to release it in the nearest days.

Sorry for the inconvenience.

I’m facing the same issue, but it caps at about 10 mbit/s
using another ftp client on the server and transfering the same files (also using the same SFTP methods) is at about 250mbits. What could limit it in SQLBackupAndFtp?

the log says it is 1023,9 KB/s
(in all tries)


Could you please enable “Use large buffers” option at the “More FTP Settings” dialog and try again?

That is enabled already. I also tried turning it off with not difference.

The SQL Server is running at 59GB used of 64GB RAM. May this implicate problems?

I disabled “Use large buffers” and it was about 30 mbit/s (before that it was 8-10 mbit/s)
Then I reenabled it and it is now 135 mbit/s

So it seemed to be wrong in the first place? Anyway it’s working now. Turning it off an on again worked :slight_smile:

Now I found it. The bug is still there.

As soon as I close the application it slows down to 10 mbit/s (running from the background windows service then). When I reopen SQLBackupAndFtp it’s back to full speed. What is going on?


SQLBackupAndFTP always uploads a file to a destination using the windows service. When you open SQLBackupAndFTP application, the application just monitors your jobs using duplex channels.