Failed to backup database with "Full" backup type - Sql Server 2005

The version I just installed (11.7.3) apparently does not backup Sql Server 2005 (only 2008 or later). I selected a Remote Sql Server backup.

My old version did (9.0.37). It’s been a while since I did this. Is there any solution to this or just to use the old version?


Hi Gary,

We need more details to investigate this case. Could you please tell us, do you receive any error messages? If yes, please send us a screenshot of this issue or a full text of the error message?

Sorry for the inconvenience.

Sorry for the delay in responding, Alexander.

I am attaching a screen shot of the error. I tried the current version and received the same error - screenshot also attached.

Hi Gary_Davis,

Thanks for the screenshots. You got the following error message:

"This method or property is accessible only while working against SQL Server 2008 or later."

Sorry, but this issue is generated by SQL Server. It seems you use a very old version of SQL Server that doesn’t support scripting. Could you please try to perform scripting manually via SQL Server Management Studio.

Sorry for the inconvenience.

Thanks. I will continue to use the V9 version of SqlBackup which does apparently work with the 2005 Sql Server.

Hi Gary_Davis,

Thank you for your reply and sorry for the inconvenience.