Error starting SqlBak Service

I am trying to install the program on Windows Server 2012 R2. When the program starts I get the following error.
Error: SqlBak service is stopped… I click the restart service and it gives the following error.
[sc] StatService FAILED 1053

Thank you for the issue reporting, we’ll check and fix it as soon as possible.


Please check Windows Event Log for error records related to “SQLBackupAndFTP Client Service” windows service.

I am having this same issue but on Windows 10. I have tried installing the software and it always throws the error that SqlBak.Job.Cli has stopped working.


Could you please check are there any error messages in the Windows Event Log?

Application: SqlBak.Service.exe
Framework Version: v4.0.30319
Description: The application requested process termination through System.Environment.FailFast(string message).
at System.Environment.FailFast(System.String)
at .‭‏‪‮‭‏‌‬‬‌‏‬‬‭‪‮‭​‍​‪‍‍‍‬‫‮()
at …cctor()
at Pranas.Net.SqlBak.Service.SqlBakService+<>c__DisplayClass1_0.b__0()
at System.Threading.Tasks.Task.Execute()
at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
at System.Threading.Tasks.Task.ExecuteWithThreadLocal(System.Threading.Tasks.Task ByRef)
at System.Threading.Tasks.Task.ExecuteEntry(Boolean)
at System.Threading.ThreadPoolWorkQueue.Dispatch()

Faulting application name: SqlBak.Service.exe, version:, time stamp: 0x59708768
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0x80131623
Fault offset: 0x00007ffd82623566
Faulting process id: 0xa278
Faulting application start time: 0x01d30194e970a906
Faulting application path: C:\Program Files (x86)\SQLBackupAndFTP\SqlBak.Service.exe
Faulting module path: unknown
Report Id: 4a246f6f-f71a-4bef-982c-ecf4683a6b07
Faulting package full name:
Faulting package-relative application ID:

Thank you for the details. Could you please clarify, do you use any Profiler?

Profiler like what? I do have SQL Express installed on these machines.

Could you please clarify what version of .NetFramework do you use?

4.7 is installed on my machine

Thanks for the details.

Could you please send us a full Windows Event Log to check this issue.

To make it private please send it to

Did it help ? What was the issue?

I have same problem

Could you please make sure that you use at least .NetFramework version 4.0 Also could you please tell us what version of SQLBackupAndFTP do you use?

Windows Server 2016, with Framework 4.0 and 3.5 installed

Sorry for writing in two threads (this and Service has stopped working)

I had version 11.1.15 (which stopped working on November 9) and as I measure I tried uninstalling it and installing newest. Currently I have version 11.3.9

Important note:

On November 9 I have installed Windows Server icence (it was Trial Edition) and rebooted. After reboot I have error in event log:

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID 
 and APPID 
 to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

This was the first time I received such error and afteward I receive it every time when I try to start SQLBackupAndFTP service.

Thank you for the details.

You might need to provide permission using the below instruction.

  1. Click Start > Run > Type > dcomcnfg, expand Component Services > Computers > My Computer > DCOM Config.
  2. Click View > Detail -> Now you will get Application Name and Application ID in right side.
  3. Scroll down and find the application ID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} > Right Click > Properties and select the Security tab.
  4. Click Customize under “Launch & Activation Permission” > click Edit > Add in the account serverName\UserName and set local launch and local activation.
  5. Restart the application Service linked to this Application ID or restart the server and monitor

I’m getting the same error as @emorinbb. How can I fix it?


Could you please tell us what versions of .Net Framework and SQLBackupAndFTP are installed on your server?

Also, have you tried the suggestions above?

Sorry for the inconvenience.

Hi! We’v faced with almost the same issue, it occurred after installing OneAgent from

Service is not starting… I can’t see if we have any event with DCOM (looks like our application log is truncated). Application ID {9CA88EE3-ACB7-47C8-AFC4-AB702511C276} is RuntimeBroker and security settings are disabled for (i’ll look forward why).

But in any way first service shutdown was after dynatrace OneAgent started… (17.06.19 06:18 +3 UTC at system event log)

We’ll send event logs to mail you’v provided