Error on PostgreSql backup

Since this morning we are having the following error:

8.45.00 Starting scheduled job “backup-data” - “Full”. Server “SERVER”. System account “SYSTEM@SERVERDOMAIN”. App v.“12.7.19”.
8:45:00 : Connecting to “PostgreSQL Server”: “XXX.XXX.XXX.XXX”.
8:45:00 : ERROR: Job execution error: C:\Program Files (x86)\SQLBackupAndFTP\DBMS\PostgreSql\psql.exe has exited with -1073741511 code. Server name: “SERVER”.
8:45:00 : Deleting temporary files.
8:45:00 : ERROR: Job “backup-data” finished with “1” errors.

What can we look at? The error does not tell us much about the problem .


I add some comments.
If I try to test the connection from SqlBackupAndFTP it fails with the same error.
Attached is a screenshot.
From our own applications and with pgAdmin we connect without problems.

Hello SB1,

Could you please go to your connection settings, press the info button, copy the command, and run it using the Command Prompt to check if the connection can be established?

Please ensure you have specified the password during the connection via Command Prompt.

If you have any other questions, please let us know.

Thank you, and we apologize for any inconvenience caused.

Hi, i try run the command and an error appears:

The procedure entry point GetSystemTimePreciseAsFileTime could not be located in the dynamic link library Kernel32.dll

With Path to PostgreSQL bin folder empty the test path used is
C:\Program Files (x86)\SQLBackupAndFTP\DBMS\PostgreSql\psql.exe and the connection test fails.
If I change that path to the real path of PostgreSQL C:\Program Files\PostgreSQL{version}\bin\psql.exe the connection test works.
The server where SqlAndFtpBackup is installed belongs to a customer, we only handle database related stuff and have not installed/uninstalled anything. But it could be that the server administrator did and that has affected it, what could we check?
Thank you very much.

Dear Sebastián,

Thank you for the details.

We are sorry, but it appears that the only way to successfully establish a connection to your PostgreSQL database is by setting a path to your bin folder.

If you have any other questions, please let us know.

Thank you, and sorry for the inconvenience.

Hi, I had provisionally done that. It will remain as a final resolution.
Thank you!

After using the SQLBackup program for over a year, I have a user who just started having the same problem as described in this post (error -1073741511 when executing “Run Now”). I believer this is being caused by their inability to connect to the databases since the “Test connection” fails.

So on the connect screen (under Advanced Settings) I had them fill in the “Path to PostgreSQL bin folder” with “C:\Program Files\PostgreSQL\9.5\bin” (9.5 is their Postgres version#). However the test connection still fails. So setting a path to the “bin” folder is not the solution in this case

I noticed on their connect screen the Server name is “Localhost” but when we actually open the Postgres app “localhost” must be used or else the connection to Postgres fails. Could that be the problem? The SQLbackup server connect screen does not allow anything to be entered except for “Localhost” so is there a way I can change the server name to “localhost” to see if that is the problem?

Hello Jack_Brown,

Could you please provide us with a screenshot of the issue?

Note: The server name should be specified the same as you use during a manual connection.

Please let us know if you have any other questions.

Thank you, and sorry for the inconvenience.