Destination connection. > Access is denied

Getting a destination error Access is denied trying to send backup to another computer on the network after updating to the latest version.

7/5/2018 8:34 AM Starting job “Shirleys SQL Backup.jobx” - “Full”. Computer “SERVER”. App v.“11.7.1”
7/5/2018 8:34 AM The backup folder “C:\Program Files\Microsoft SQL Server\MSSQL10_50.CESSQL\MSSQL\Backup” has “424.572GB” free space. The temporary folder “C:\Windows\system32\config\systemprofile\AppData\Local\Temp\SYSTEM\Pranas.NET\SQLBackupAndFTP\backup” has “424.572GB” free space
7/5/2018 8:34 AM Backing up “.\CESSQL” SQL Server databases
7/5/2018 8:34 AM Getting maximum file size…
7/5/2018 8:34 AM The maximum file size: “”
7/5/2018 8:34 AM Backing up “fpos5” database to .bak file. Backup type: “Full”. Checksum: “Disabled”
7/5/2018 8:34 AM “fpos5” database backup successfully completed. Backup type: “Full”
7/5/2018 8:34 AM Database “fpos5” successfully backed up to “fpos5201807050834.bak : 1.220GB”
7/5/2018 8:34 AM Compressing “fpos5201807050834.bak” file with Internal archiver. Encryption: “Off”
7/5/2018 8:36 AM Backup of “fpos5” successfully compressed to “( : 166.744MB)”
7/5/2018 8:36 AM Connecting to FTP destination “
7/5/2018 8:36 AM The current destination folder is “home”
7/5/2018 8:36 AM Sending backup of “fpos5” to FTP destination “
7/5/2018 8:36 AM Uploading local “” to remote “” in folder “home”
7/5/2018 8:41 AM Uploaded 100 % (average speed = 589.4 KB/s)
7/5/2018 8:41 AM Disconnecting from FTP destination “
7/5/2018 8:41 AM Connecting to Folder destination “\Term1\c\FPOS5\Data”
7/5/2018 8:42 AM Destination error: [DST-1:1003#5] Failed to open “\Term1\c\FPOS5\Data” destination connection. > Access is denied
7/5/2018 8:42 AM Cleaning up backups of “Shirleys SQL Backup.jobx” job
7/5/2018 8:42 AM Cleaning up backups of “fpos5” database at FTP destination “
7/5/2018 8:42 AM Job “Shirleys SQL Backup.jobx” finished with “1” errors


Could you please clarify what version of SQLBackupAndFTP have you used before when everything was working?

Could you please open you “FTP Server Settings” window and click “Test” button to check the connection?

We were using Version now we’re trying to use 11.7.1. The FTP connection Test and backs up just fine. It’s the local network folder that is giving us the access is denied error.

Hi Dan,

Thanks for the feedback. Please feel free to contact us on any issues or concerns.

Can I get some help or ideas why it gives me the access denied error on the local network? the FTP works fine.

Hi Dan,

Didn’t notice that the issue with the local network folder, sorry. Could you please make sure that you have specified your User Name like “domain/user”?

Sorry for the inconvenience.

Not 100% sure what I should be putting in here. we don’t use any windows password with the Administrator user and we are just using workgroup not a domain.

Hi Dan,

Yes, please specify your workgroup as a domain.

Next suggestion.

Hi Dan,

If it didn’t help, could you please try to specify the name of the computer to which you connect as a domain?

Sorry for the inconvenience.

I have the same problem.
SQL server, sqlbackupandftp are in a oracle virtual box.
I want to backup towards the sharedfolder between virtual PC and physical PC, which is named “\VBOXSVR\SharedFolder” when opened from the virtual PC explorer.

the “open folder” link works correctly.

I don’t know how to configure this username and password things. I tried all combinations possibles.

these are logs for my problem
thank you for helping

2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Tools.Wcf.WcfExtensions|CloseClient. The channel client has closed
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Tools.Wcf.WcfExtensions|UsingA. Return
2018-12-28 10:27:45.7527|DEBUG|48|Net.Pranas.SqlBak.Destination.Folder.FolderConnection|DoOpenConnection. Path: “\VBOXSVR\SharedFolder\backup_SQL”
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.FolderConnection|DoOpenConnection. Connecting to network shared folder… ShareName: “\VBOXSVR\SharedFolder”; UserName: “”; PasswordLength: “0”
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.FolderConnection|DoOpenConnection. Mapping drive… Force: “True”; LocalDrive: “”; SaveCredentials: “True”; ShareName: “\VBOXSVR\SharedFolder”; Persistent: “False”; PromptForCredentials: “False”
2018-12-28 10:27:45.7527|DEBUG|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZMapDrive. Username: “”; PasswordLentg: “0”; Environment.UserName: “seva”; Environment.UserDomainName: “WINDOWS10”; Environment.UserInteractive: “False”
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZMapDrive. Force drive unmapping…
2018-12-28 10:27:45.7527|DEBUG|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZUnMapDrive. Force: “True”
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZUnMapDrive. Invoke WNetCancelConnection2A… ShareName: “\VBOXSVR\SharedFolder”; Flags: “0”
2018-12-28 10:27:45.7527|DEBUG|52|Net.Pranas.SqlBak.Context.Context.Data.RoutinesDatabaseHandler|LoadJobBackupLogRecords. Return: “Net.Pranas.SqlBak.Log.Trace.JobBackupLogRecord[]”
2018-12-28 10:27:45.7527|DEBUG|52|Net.Pranas.SqlBak.Context.Context.Data.RoutinesDatabaseHandler|LoadBackupObjectInfo. LocalBackupId: “27”
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZUnMapDrive. WNetCancelConnection2A Result: “2250”
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZUnMapDrive. Just trace the exception|System.ComponentModel.Win32Exception (0x80004005): This network connection does not exist
2018-12-28 10:27:45.7527|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZMapDrive. Invoke WNetAddConnection2A function… NetRes: “Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2+StructNetResource”; Flags: “4096”
2018-12-28 10:27:45.7527|DEBUG|52|Pranas.Net.SqlBak.Service.SBF.DesktopAppService|LoadDeltaJobLogDetail. Return: “IsSuccess: True; Error: “”; Value: “SBF.Channel.Contract.DataContract.JobLogDetailDelta””
2018-12-28 10:27:46.6182|DEBUG|16|Quartz.Core.QuartzSchedulerThread|Batch acquisition of 0 triggers
2018-12-28 10:27:48.0196|TRACE|48|Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2|ZMapDrive. WNetAddConnection2A result: “67”
2018-12-28 10:27:48.0196|ERROR|48|Net.Pranas.SqlBak.Destination.Folder.FolderConnection|DoOpenConnection. System error on connecting to the folder destination|System.ComponentModel.Win32Exception (0x80004005): The network name cannot be found
à Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2.ZMapDrive(String psUsername, String psPassword)
à Net.Pranas.SqlBak.Destination.Folder.FolderConnection.DoOpenConnection()
2018-12-28 10:27:48.0196|ERROR|48|Net.Pranas.SqlBak.Destination.Core.ConnectionBase|Open|Net.Pranas.SqlBak.Destination.Core.DestinationException: [DST-1:1003#67] Failed to open “\VBOXSVR\SharedFolder\backup_SQL” destination connection. —> System.ComponentModel.Win32Exception: The network name cannot be found
à Net.Pranas.SqlBak.Destination.Folder.Network.NetworkDrive2.ZMapDrive(String psUsername, String psPassword)
à Net.Pranas.SqlBak.Destination.Folder.FolderConnection.DoOpenConnection()

Hi arnaud,

Thanks for the details. Please give us some time to investigate this case.

Sorry for the inconvenience.

I’m using the new Standard version – Similar Problem to those here – I’ve used a previous version for years with no problem. Today, I downloaded the new version for a new computer and tried for hours to make it work. With most attempts using TCP/IP, I am told “Using a password on the command line can be insecure. ERROR 1044 (42000) Access denied …” Other attempts pretty much just said “no”. But when I use setting I’m sure of, I get the ERROR 1044.

With the PhpMyAdmin attempt, I’m told 404 - Not Found.

I’ve checked to be sure my IP address is okay with the hosts – I’m using two hosts. No connection possible with TCP/IP or with PhpMyAdmin with either of them.

Is there a typical thing I should check?


We have added some changed to SQLBackupAndFTP (alpha), could you please install the following version and check if it resolves the issue.

If you still have that error message please go to the “Connect to Server” window and click on the “info” button. Then copy the command and execute it via the Command Prompt to check if you get any error message?

Sorry for the inconvenience.

I have the same issue, I tried what you requested above and here is the result:

C:\Users\ddd52>“C:\Program Files (x86)\SQLBackupAndFTP\DBMS\MySql\mysql.exe” --host --port 3306 --user “database” --password="**********" --html --execute “SHOW DATABASES;” “mysql”
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1045 (28000): Access denied for user ‘me’@‘’ (using password: YES)

Alexander – Thank you. The new program version solved problem #1, but now there’s a new issue:

First – I downloaded your alpha version of the program and the new version connected to my databases immediately. All looked good. I chose the databases for it to download and told it to run.

Second – The process failed. It got as far as:
Getting maximum file size …
The maximum file size is: " "

It let it run for an additional four minutes but nothing happened.

I tried it on the second site on the other host. Again, it connected beautifully. I chose the databases I want to back up. Again, It got as far as:
Getting maximum file size …
The maximum file size is: " "

Then it just sits there with the little icon going around.

I hope this description helps identify the code that needs to be addressed.


Hi guys,

To investigate your issues we need more details. Could you please enable the advanced log, reproduce the issue and send logs to our dev team to check it? Please find more details on how to do it at

Please let us know when the log will be sent. Also please provide us with your application id to identify the log. You can find it by clicking “Help” > “About”.

Sorry for the inconvenience.

Great – Thanks for looking into this. I’ve attempted a backup with the logging enabled and sent you the log.

My id is: dc045ecc-13bb-439c-872d-5abe6dde56fb

Thanks, Mike

I didn’t test 100 % but at first sight it seems that new release SQLBackupAndFTPSetup.alpha solved my problem

thank you !