\DBMS\MySql\mysql.exe"' is not recognized as an internal or external command - ALL Backups on various computers are failing with this error as of yesterday

Since yesterday nearly all my backups are failign with the following message

• 10:24:36 AM : Starting job “PEGC Server Backup” - “Full”. Computer “SERVER”. App v.“12.1.0”
• 10:24:37 AM : ERROR: Job execution error: ‘“C:\Program Files (x86)\SQLBackupAndFTP\DBMS\MySql\mysql.exe”’ is not recognized as an internal or external command,operable program or batch file. Computer name: “SERVER”

please can you advise.

Resolved : the file mysql.exe was deleted from the DBMS folder. No idea though why this has happened to so many random people. Re-install the software or copy the file to the foldfer and all is srted.

I would like to add to Johannes support request by adding that my backups also failed last night with exactly the same error! We are using v12.0.4 and no Windows updates have been applied this week.

I appear to have resolved the problem (for now?) by re-executing the setup file.

Strangely, the “C:\Program Files (x86)\SQLBackupAndFTP\DBMS\MySql\mysql.exe” file does not exist before or after the re-install?

Please advise.

Same issue here. Also this error vanished when re-executing the setup file.
But after that there is another issue:
Each backup fails with the error "ERROR 1044/42000): Access denied for user “xxxxx@xxxx.xx” to database “mysql”.
The cause is the way sqlbackupandftp (now) accesses the database: This is not possible in the security context of our server.
Prior to last update, everything worked fine in the same security context.

It looks like in the recent update there were some amendments that in some environments do not work. Any way to give the user the choice to use the old method?
Has anybody tried a downgrade?

Seeing the same issue here, all working on the 29/12 but now failing. The “MySQL.exe” file that is referenced in the error doesn’t exist in the file system (see image below)

After investigating, for some reason on all our computers the mysql.exe file was removed from the sqlbackupandftp folder.

re-installing or copying the file back solved it.

Question remains why is that file being removed from so many computers on the same day I guess.


This is a temporary issue on our side and we’ll fix it as soon as we can.

Sorry for the inconvenience.

That was a temporary issue on our side which is fixed now. Could you please make sure you use SQLBackupAndFTP version 12.1.1. Your application should be upgraded automatically. If it doesn’t you can do it manually by clicking “Help” > “Check for updates…”.

Sorry for the inconvenience.

We have installed v12.1.2 and afraid that there are still problems even though we have confirmed the existence of the mysql.exe.

We are receiving the following emails:
Subject: The MySQL Server connection on [SERVER] is offline as 01/01/2019 12:42:54
Body: The computer itself is online, but the SQLBackupAndFTP service connection on this computer receives no communication from the MySQL Server [IP]:3306 . This means that the MySQL Server has stopped, restarting or the login used by SQLBackupAndFTP service running on this server has changed. The MySQL Server backups from SQLBackupAndFTP will not run until the communication is restored.

On running the “Test Connection” feature, the following error is usually (but not always) displayed:


We have added some changes to SQLBackupAndFTP, could you please download the following release https://sqlbackupandftp.com/download/alpha and test it.

If it doesn’t help, please enable the advanced log, reproduce the issue and send logs to our dev team. Here are more details on how to do it at https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

Please let us know when the logs will be sent. Also please provide us your application id to identify the log. You can find it by clicking “Help” > “About”.

Sorry for the inconvenience.

Updating to 12.1.2 resolved the issue for me

And now with 12.1.2 the app keeps sending me offline and online service emails every 5-10 minutes. Guess I’ll have to turn that notification off for a while sigh.

As of January 1, I am getting this when backing up a instance: (works towards another almost identical instance… no changes to either client nor server known…)

10:27:15 PM : ERROR: Job execution error: mysql: [Warning] Using a password on the command line interface can be insecure.ERROR 1045 (28000): Access denied for user ‘xxxx’@‘xxxxx’ (using password: YES)‘s@s’ is not recognized as an internal or external command,operable program or batch file.

Related issue?

The update from the download/alpha link above… 12.1.2 -> 12.1.2 … solves this issue for me.

Hi guys,

The issue:

ERROR: Job execution error: mysql: [Warning] Using a password on the command line interface can be insecure. ERROR 1045 (28000): Access denied for user ‘xxxx’@‘xxxxx’

was resolved in the latest alpha version https://sqlbackupandftp.com/download/alpha

We’ll check the issue with offline and online service emails.

Sorry for the inconvenience.

Hi Alexander

I installed the Alpha version Wednesday morning and the good news is that it now appears to be working as expected. The service monitoring feature and scheduled auto backups are now working again.

However, I do have a follow-up question: Our database server is offline every night for a few minutes while a VM backup is made. Would it be possible to add a schedule for the service monitoring feature?

Thank you for being so responsive.

Hi John_Randall,

Good news! Thanks for the reply and for the feature request, we’ve redirected it to our dev team.