Couldn't execute "show binary log status"

Dear all,

I have a back up runnuing for month without problems.
this night it stopped working with following error message:

mysqldump: Couldn’t execute ‘SHOW BINARY LOG STATUS’: You have an error in your SQL syntax

Has anybody an idea what’s the problem?



Hello Stefan_Kern,

To resolve the issue, we need more details. Could you please check the application version when everything was working correctly, and the application version number when you started receiving this error message?

The application version number is typically stored in the first line of the backup log.

Please let us know if you have any other questions.

Thank you, and we apologize for the inconvenience.

Hi Alex,

thanks for your reply.
The issue is solved now.

What I found out:
I used to use MySQL Server Version 8.0.2 which does not know the SHOW BINARY LOG STATUS command. I upgraded to MySQL 8.2. and the sqlbackupandftp started working again.
I think that you replaced the SHOW SLAVE STATUS command by the SHOW BINARY LOG STATUS .
What I wonder: Does mysqlbackupandftp automatic updates?
I think yes, but I did not update the program. Can I turn automatic updates off?



I am running into the same issues with MySQL 8.0.32. It looks like the SHOW BINARY LOG STATUS replaced SHOW MASTER STATUS, that was deprecated in MySQL 8.2.0. Do I need to go back a couple of version with sqlbackupandftp or do I have to upgrade MySQL to version 8.2.0 and higher for this to work?

Hi Adam,

I updated MySQL to 8.2.0 and it worked.
But I wonder where to disable automatic updates in MySQLbackuopandftp …

I am just not sure about how easy it will be to upgrade MySQL to 8.2. Its intergraded into a software stack we have build and would need to go through some major testing.

Hello everyone,

We have made some improvements to the Alpha edition. Could you please install it from here and check if the issue is resolved for you?

Please let us know if you have any other questions.

Thank you for using SQLBackupAndFTP, and we apologize for the inconvenience.

At this time the updated version did not help. It looks like MySQL version 8.0.x does not know the SHOW BINARY LOG STATUS command that is being used. I was really hoping not to have to force upgrade to MySQL 8.2 to use this backup tool for running incremental backups.

Hi Adam,

I did the update to MySQL 8.2 and I can say that it worked without any issue.



Hello Adam_Ouellette,

Could you please confirm whether you had the opportunity to update your MySQL Server to version 8.2 and check if the issue has been resolved?

If you have any other questions, please feel free to ask.

Thank you and apologies for the inconvenience.

Hi Stefan,

Great news! Thank you for the update!