Confirmation test-email via GMail gives error message


I’m running SQLBackupAndFTP Standard, version 12.5.2. Unfortunately I am dealing with Internet connections that are not always reliable. Hence I want to set up the confirmation email in case of backup faillure.

I’ve set up the Mail Server Settings to use GMail. However, when I click the button Send Test Email, the system gives me the following error message: - gsmtp (534).

Can you tell me what’s going wrong?


1 Like

Hi Erwin,

Sorry, but the link you sent cannot be opened. Could you please follow the link you get in your error message and follow the instructions that Google suggests?

Thank you and sorry for the inconvenience.

Hi Alexander,

The link didn’t help, but in the mean time I have discovered the solution!

To allow SQLBackupAndFTP to use the GMail SMTP, it should be added as an allowed app in the security settings in the Google account. It then generates a special password that should be used in the SMTP settings in SQLBackupAndFTP, instead of the normal password used to log into the email account.

Hopefully this info will save other people a few headaches and time searching why things don’t work.



Hi Erwin,

That’s great! Thank you for sharing the instruction!

Thank you!

Thank you Erwin for putting me on the right path. Here is some additional info for those reading this thread:

To create the custom email password for your gmail account that SQLBackup and FTP can use go to:

Manage your Google Account


Signing in to Google

App passwords

It will ask you to sign in to your account to confirm your identity

The screen will say “Your app passwords”

click the down arrow next to Select App and select “Other(custom name)”

Enter “sqlbackupandftp”

Click on “generate”

Copy the password you see, and go back to the SQLBackup and FTP email notification screen, and enter the password in the field for your gmail account password.

Thank you very much !!!

Gmail no longer allows App Passwords. I just got a new computer and migrated the SQLBackupand FTP from the old computer. It’s running Windows 11 Pro. I can not get the application to send a confirmation email. I’ve tried 'Gmail" and ‘Custom’ with no sucess.I had to change a couple of other apps to OAUTH, but SQLBackupandFTP doesn’t provide that option. When I try to send a test email with the Gmail setup, I get: Check Gmail through other email platforms - Gmail Help f28-20020a056638113c00b00375ac4c5c02sm2654006jar.76 - gsmtp (535).
When I try it with the Custom setup SMTP setup, I get a similar message.

Any syggestions?

Hello Gary_McCray,

Sorry, but the issue cannot be resolved from our side. Could you please try to path the steps that Google recommends?

Note, in your Google Drive account settings, it is necessary to allow access to unsafe applications.

Please let us know if you have any other questions.

Thank you and sorry for the inconvenience.

Google no longer allows the addition of “less secure applications.” A third party application can no longer log into Gmail with only a user name and password. I have had to change 2 other applications to OAUTH in order to gain access. Do you think SQLBackupandFTP will add that functionality in the future?

Hello Gary_McCray,

Thanks for the details, we will consider your request.

Thank you and sorry for the inconvenience.