Configuration of automatic deletion in temporary files


I need help with a configuration.

The connections got error because the local disk got full, the image of the jobs are not deleted automatically.

We are working with an Azure virtual machine.

Is there any way that the backup images that are saved on the local disk are deleted after the task is done.?
We save the backups in Droxbox.

PS/ The message was translated to English by Deepl, sorry if there are errors.

Hello Luis_Benedetich,

SQLBackupAndFTP operates as follows:

  1. It creates a backup file in a temporary folder.
  2. The backup file is then compressed within the same temporary folder.
  3. After compression, the original backup file is removed.
  4. The compressed backup file is sent to the selected destination locations.
  5. Finally, the compressed backup file is removed from the temporary folder.

This process requires sufficient free space to store both the backup files and compressed backup files simultaneously.

Additionally, you can enable the auto-delete option to remove old backups from your chosen destination within the destination settings.

If you have any further questions, please do not hesitate to ask.

Thank you, and we apologize for any inconvenience.

Hello Alexander.

Thank you for your comments.
I understand that this is how you describe it, I read the guides you offer.

The problem, which I failed to comment, is that the temporary files were not deleted, maybe this is due to a bug (?).
When it happened, I had to go and delete them manually.

So far, the problem has not happened again.

Thank you!

PS/ The message was translated to English by Deepl, sorry if there are errors.

Hello Luis_Benedetich,

The issue you have encountered can occur if the SQLBackupAndFTP (Database Backup) Window Service crashes during its operation (when a backup job runs), leaving temporary files on the disk.

We apologize, but there is nothing we can do to prevent this.

Thank you for using SQLBackupAndFTP, and we apologize for any inconvenience this may have caused.

Hello Alexander.

Thank you for your comments.
So far the bug didn’t happen again, we are working normally.
I had to tell you what happened, in case there was some configuration that was not optimized.

Thanks for your support.

Hello Luis_Benedetich,

Sure, please feel free to contact us on any issues or concerns.