Column-statistics error

Hello, I have migrated from MySQLBackupFTP to SqlBackupandFTP v.12.0.4.
All the jobs were migrated without problems, BUT when I execute the job, it returns the following message:

12/20/2018 18:35 Starting job “UNI.mjobx” - “Full”. Computer “SERVER”. App v. “12.0.4”
12/20/2018 18:35 Connecting to MySQL Server: (5.1.60-community). myserverIP
12/20/2018 18:35 The backup folder “D:\BACKUP\Pranas.NET\SQLBackupAndFTP\backup” has “29,194GB” free space. The temporary folder “D:\BACKUP\Pranas.NET\SQLBackupAndFTP\backup” has “29,194GB” free space
12/20/2018 18:35 Backing up “myserver” databases with mysqldump.exe: See 10.13 Distrib 5.7.24, for Win32 (AMD64)
12/20/2018 18:35 Getting maximum file size …
12/20/2018 18:35 The maximum file size: “”
12/20/2018 18:35 Failed to backup “ncargas” database with “Full” backup type: “C: \ Program Files \ MySQL \ bin \ mysqldump.exe” error: mysqldump:
mysqldump: [ERROR] unknown variable 'column-statistics = 0’
12/20/2018 18:35 Cleaning up backups of “UNI.mjobx” job
12/20/2018 18:36 Job “UNI.mjobx” finished with “1” errors
12/20/2018 18:36 Sending job log to abc @ mymail

I executed the command mysqldump from the command line, without writing “–column-statistics = 0” and it worked without problems.

Is there any way to prevent this parameter from being added by default?



Thanks for the details. Could you please go to the “MySQL Backup Options” and set “Generate statistics histograms” to “Default” it should resolve the issue.

Sorry for the inconvenience.

It works!!
Thank you very much!

Good news! Please feel free to contact us on any issues or concerns.

Hi Alexander,
I have followed the steps and it works correctly. However, the parameter is not saved and is always displayed as “NO”.
That is, if I modify it to “DEFAULT” and execute it, it works perfectly (before I press "Save & Close, obviously).
But if I change to another JOB or close the application, when I edit the JOB again, I notice that it is “NO”.
Any suggestions?

Alejandro (Argentina)

In addition, i’m using 12.1.1 version.


Thanks for the details.

That issue has been fixed in the latest release - version 12.1.2. Your application should be upgraded automatically. Also, you can download the latest release at

Sorry for the inconvenience.

I am using v12.3.11 Professional, and backup several databases on different local servers. Two of them fail backup with the “mysqldump: [ERROR] unknown variable 'column-statistics = 0’” error, but the others back up OK. They all started with “Generate statistics histograms” to “Default” set to “Default”. I tried all the options for that setting on the two that fail, and none works.

Hi Steve_Hart,

Thank you for the details.

Could you please try to perform backups manually via mysqldump tool and check if it works for you?

Sorry for the inconvenience.