Can't send email : Object reference not set to an instance of an object

i don’t get notification anymore from SQLBACKUP.
here is the error:
Can’t send email to “” Object reference not set to an instance of an object.
How can i solve this ?
Tahnk you for your support

1 Like


Same Here, Folow…

Same here. Not all of my setups are doing it but a couple are. It started happening after testing the ftp settings one day. We still get the email if we hit the test email button.

I think this is a bug in the latest version of the software. I have v12.4.13 Standard installed (brand new installation/license) and we are experiencing this problem as well. My settings below…

Mail Server: Custom
From email:
SMTP mail server:
SMTP Port: 25

The strange thing is “Send Test Email” works. But when I run the job the email fails to deliver when it is completed.

SOLUTION: Download the latest version they just released - v12.4.14

This bug is fixed in that version.


Thank you Michael, i installed the v 12.4.14. and all work fine now.

1 Like

v12.4.14 Fixed it for me as well.

1 Like

Hello guys,

That issue has been fixed in the latest release of SQLBackupAndFTP - version 12.4.14. You can download it at the “Download” page, or run SQLBackupAndFTP and click on the “Help” > “Check for updates…”.

Sorry for the inconvenience.