Azure Storage Reporting Error 400 Bad Request

Hi, Upgraded to use your Azure Storage feature. However have run into a problem. When configuring the dialog box with the AZURE Account / Key / Container and pressing TEST, receive error 400.

Troubleshooting this with AZcopy have found that if I use https it works correctly, but http generates the same 400 error.

How do I configure the software to use https and not http for the connection string? I don’t want to deselect “secure transfer required” in Azure.



To solve this issue could you please check the way you have specified your container name. You can check it at the destination settings.

This name may only contain lowercase letters, numbers, and hyphens and must begin with a letter or a number. Each hyphen must be preceded and followed by a non-hyphen character. The name must also be between 3 and 36 characters long.

Thank you Alexander for such a prompt response.

Interesting - I had a container with a path spec - folder1\folder2. Removing \folder2 solved the problem.

So does that mean I cannot have nested folders (AZCopy can leverage)?


You can specify the path to the required folder at the “Path” box at the “Advanced Windows Azure Storage Settings”.