After Update failure 11.1.13 to 11.1.15 program not starting service

Hi, After failed update v11.1.13 to v11.1.15 and failed auto rollback the program is not starting the SQLBackupAndFTP Client Service.

I removed the program and after a reboot I installed the newest version again. The problem is still there. I’ve tried the “delayed start” option but …nope

System: Server 2008 r2

Event log:

Log Name: System
Source: Service Control Manager
Date: 7-8-2017 10:49:56
Event ID: 7000
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: xxxxxxx
The SQLBackupAndFTP (SQL Server backup) service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.
Event Xml:




SQLBackupAndFTP (SQL Server backup)

Hope you can help!



Thank you for the issue reporting, we are working to solve this issue.

ok,thanks! maybe installing a older version in the meanwhile?


We have released SQLBackupAndFTP 11.1.16 with a fix for this issue.
Could you please install the latest version of the application and check it?
Thank you!


Sorry still the same problem… When I do a clean install I noticed the Installer is “hanging” a long time at ‘installing sqlbackup…service’. The setup completes but the program is not starting the service (please start again is showing)

Could you please tell us more details about this issue. Do you use any antiviruses or profilers?

It’s a very basic VM 2008 r2 server running exact globe with about 90 sql-databases. No AV and fully updated. SQLbackupAnd FTP is running for a couple of years now without any problem. As I mentioned before the problem started while updating 11.1.13 => 11.1.15. halfway through the update proces it hangs and automatically rolled back (what went wrong as well). I unistalled the prog, downloaded 11.1.15, installed it after install openend the prog and directly I got the message “slqbck” service isn’t started. Click here to start service. A cmd opens, service is trying to start but after a while “the service could not be started in a timely fashion”.

What more info do you need? Let me know.


A timeout was reached (30000 milliseconds) while waiting for the SQLBackupAndFTP (SQL Server backup) service to connect.

This issue has been fixed in the latest version of SQLBackupAndFTP version 11.1.18. Could you please uninstall your current version and install the latest one. You can download it at

If you still have this issue with the latest version please save the NLog.config file into the application folder C:\Program Files (x86)\SQLBackupAndFTP, restart “SQLBackupAndFTP (SQL Server backup)” Windows service, run the backup job and send us all log files from C:\Log\SBF folder after this issue happens again.

To download Nlog.config file please follow this link

To make it private please send to

Pfffffff this program… now for the third time the program stopped working…out of the blue. Same error same problem. Al since the new interface. I don’t have the time fiddling around with this program every few weeks and this is the last time I’m going to. Please give me a solution for this annoying problem. Thank you.

7-2-18 program stopped after auto update…


Could you please tell us do you use any Proxy to connect to the internet?

Also, please clarify, what version of SQLBackupAndFTP do you use?

Hi there, I’m using 11.4.4. I dont use proxy. I’ve got it working again. I don’t know why but after reinstall 6 it worked again.

Off topic:
Strange, after 2 day’s of working correctly now the program shows ‘free’ version (I installed the key 2 days ago). I reistalled the key now its proffesional again.

Thanks for the feedback.

SQLBackupAndFTP checks the license via Internet, perhaps you haven’t had a stable connection during these two days.