7Zip Console Seems to Hang

We are using 12.5.2 – It seems like since around March 21st we have been having random issues with 7Zip Console just sitting at idle doing nothing. The backup itself completes, but the compression seems to hang and never progress further (ie, copy/move/whatever). It never finishes (have tried leaving it for 12+ hours). There is no trend on database size, we’ve seen it happen with ~100MB databases all the way through to larger databases.

If we manually kill the 7Zip Console process, it seems to spawn a replacement working process and it completes – it’s not viable to watch this daily and kill tasks to get it to move along…

We are using 7Zip 19. There have been no Windows updates on the server around the timeframe of the issue starting. This is happening across multiple Jobs and we have tried restarting the SQLBackupandFTP service with no change in behaviour. It is random…

Is anyone else having this issue? Any recommendations as this is creating major issues…


Hi David_Schmidt,

We have just released SQLBackupAndFTP version 12.5.5 with the fix of the issue. Your application should be upgraded automatically, or you can do it manually by clicking “Help” > “Check for Updates”. Could you please make sure that you use that release and check if it works for you?

Sorry for the inconvenience.

Thank you! I will update ASAP. Sincerely appreciate the fix!

Unfortunately the issue is not yet fixed. I got the exact same behavior, sadly…

Hi David_Schmidt,

Thank you for your reply.

We have just released the Alpha edition http://sqlbackupandftp.com/download/alpha with some improvements. Could you please install it and check if it works for you?

If you still have this issue, please enable the advanced log with the “Trace” level, reproduce the issue, and send logs to our dev team. Here are more details on how to do it https://sqlbackupandftp.com/blog/how-to-send-log-to-devel

Note! With the “Trace” level, a log can contain your passwords. Before sending a log to dev team please open it using any text editor and remove the information you prefer to keep in secret. You can find them by clicking the “Open folder” link at the “Advanced Log” window (“Tools” > “Advanced Log…”).

To make the logs private, please send them to support@sqlbackupandftp.com Please let us know when the logs will be sent.

Sorry for the inconvenience.

I will download and test the Alpha ASAP. Thank you, Alexander.

It looks like the issue still persists. I turned the trace logs on and will gather them and send them shortly. As before, if I kill the idle 7zip console task that is at 0% it does end up continuing, but obviously we can’t babysit all the backups live! :slight_smile:

I will post here when I send the logs.

Trace logs have been sent to support@sqlbackupandftp.com

Hi David_Schmidt,

We have just released SQLBackupAndFTP Alpha version with the fix of the issue. Could you please download http://sqlbackupandftp.com/download/alpha install, and check if it works for you?

Sorry for the inconvenience.

Exactly the same thing happens to me and I have version 12.5.5

is there already a solution for this?. Thanks

I’ve been experiencing this problem on multiple servers sporadically for the past couple of weeks as well.

Any way we can get email alerts when a backup fails to finish? Or a way to stop the task after a period of time?

Hello guys,

Could you please try to install the latest release of Alpha edition http://sqlbackupandftp.com/download/alpha and check if it works for you?

Sorry for the inconvenience.

I’ve been with the alpha version for a week and it’s working fine

Hi Ngloba_Sistemas_Onli,

Good news! Thank you for your reply.

Please feel free to contact us on any issues or concerns.