Running on a 2012 Server


#1

I’ve been a happy user of this program for a about a year. We have been running it on a 2008 server - no problem. We upgraded to a 2012 R2 server and I saw that we had to upgrade our NET version, then I realized that I didn’t see that the product supported 2012 R2. So I have not had an error yet as I have not reinstalled it on the 2012 R2 server. Should it work on 2012 R2 ? If not, is support planned for 2012 R2 servers ? What do I do ? I really don’t want to ‘just try it’ on a production server…
Thank you,
David (for WG)


#2

Hi David,

Yes, the latest version of SQLBackupAndFTP - version 11.5.2 requires Microsoft .NET Framework 4.6.0 or above and can be installed on 2012 R2 Server. In the case that for some reason there is no way to install .NET Framework 4.6.0 or above you can use SQLBackupAndFTP for older .NET Framework version 4.0.0 which can be downloaded at https://sqlbackupandftp.com/download by clicking “SQLBackupAndFTP for older .NET Framework v4.0.0”.


#3

.NET Framework 4.7.1 is supported on 2012 R2, so the main version of SQLBackupAndFTP will run just fine. More details.
Supported OS:
Windows 7 SP1 (x86 and x64)
Windows 8.1 (x86 and x64)
Windows 10 Anniversary Update (x86 and x64)
Windows 10 Creators Update (x86 and x64)
Windows Server 2008 R2 SP1 (x64)
Windows Server 2012 (x64)
Windows Server 2012 R2 (x64)
Windows Server 2016 (x64)