PostgreSQL 12 issue


#1

10/29/2019 12:35:42 PM [Error] Failed to backup “postgres” database with “Full” backup type: C:\Program Files (x86)\SQLBackupAndFTP\DBMS\PostgreSql\pg_dump.exe process has finished with “1” code. The error message: “pg_dump: server version: 12.0 (Ubuntu 12.0-2.pgdg18.04+1); pg_dump version: 11.1
pg_dump: aborting because of server version mismatch”.


#2

Hi Michael_Highguy,

To resolve the issue, could you please go to the “Connect to Server” window and specify the path to your PostgreSQL bin folder at the “Advanced settings”?

SQLBackupAndFTP

Sorry for the inconvenience.


#3

Thank you very much for replay.
Do you plan to fix it in advanvce?


#4

Here is what I did:

  1. We are using the remote windows backup server to backup instances from Linux machines
  2. I just downloaded the zip package of postgres and took the bin directory to any place and provided that directory in advanced tab of connection
  3. After that I tried to backup and got

11/5/2019 12:55:32 PM [Error] Failed to backup “postgres” database with “Full” backup type: C:\Users\michael.hi\Downloads\postgresql-12.0-1-windows-x64-binaries\pgsql\bin\pg_dump.exe process has finished with “1” code. The error message: “C:\Users\michael.hi\Downloads\postgresql-12.0-1-windows-x64-binaries\pgsql\bin\pg_dump.exe: illegal option – oids
Try “pg_dump --help” for more information.”.

  1. I unticked the object identifiers option and everything worked like a charm.

The question is: is it the bug or feature :slight_smile:


#5

Hi Michael_Highguy,

Yes, this is the feature. We have added this parameter to avoid the issue when some versions of pg_dump support this parameter and some do not.


#7

any solution please! same error


#8

Hi ak1,

That issue was fixed in the latest release of SQLBackupAndFTP - version 12.2.11 https://sqlbackupandftp.com/download Could you please install it and check if it works?

Sorry for the inconvenience.


#9

hi Alexander
i have 12.2.11…
30.12.2019 13:42:55 [Error] Failed to backup “ABC” database with “Full” backup type: C:\Program Files\PostgreSQL\12\bin\pg_dump.exe process has finished with “1” code. The error message: “C:\Program Files\PostgreSQL\12\bin\pg_dump.exe: illegal option – oids
Try “pg_dump --help” for more information.”.


#10

Hi ak1,

To resolve the issue, please go to the “PostgreSQL Backup Options” window and disable the “Dump object identifiers (OIDs)” option.

Sorry for the inconvenience.