One Drive for Business with two-factor authentication


Will this work, my backups are failing since two-factor authentication was turned on. Suggestions?


Everything is the same except now two-factor authentication is turned on for my account.
I “authorize” the location, log in, and input code. Copy and paste the authorization and get a “Connection successful,” when I click “test.”
Actually run a backup and it fails.
The log:(I was only permitted to upload 1 .jpg so a little of page 2 is missing.)


Hi Gregg,

Thanks for the details, but we need more information to investigate this case. Could you please enable the advanced logs, reproduce the issue and send logs to our developers. Please find more details on how to enable advanced logs at


Enabled advanced log and upload to developers just now after failed backup attempt.
This all started after I enabled multi-factor authentication on my Office 365 account. (This must be enabled from this point on.) Basically, I can go through your program’s authorization procedure for my One Drive for business, log in with my credentials, and input the code texted to my phone, copy and paste the authorization code, etc. It works and tests out ok but as soon as I run the backup it fails. If i test it again it also fails. There is no place within your program to use and “application password,” like say Outlook 2010 does to work with multi-factor authentication.



It seems this issue related to OneDrive for Business. We have contacted to OneDrive for Business’s support team to resolve this issue

Sorry for the inconvenience.



We have released a version with the fix of this issue, could you please install the application that can be downloaded by this link and check if it resolves the issue?

If the issue is still there, please enable the advanced log, reproduce the issue and after the issue will be reproduced send logs to developers. Please find more details on how to enable advanced log at

Sorry for the inconvenience.