Ftp server cannot accept argument


#1

Hi

I use the (older) free version of SqlBackupAndFtp (10.0.29.40602) and everything is working alright except on one computer where the message “server cannot accept argument” comes up and the FTP connection to the main server fails. If I try connecting with the exact same settings through Filezilla (on another computer) everything works perfectly. If I try SqlBackupAndFtp with the same settings on another computer everything also works fine.

So the problem must be the computer’s firewall or something. How can I find out more about this? What ports must I open and how? The computer is not using any third party software but it did have Panda Security installed earlier, which is uninstalled now.

Can someone shed some light on this?


#2

Hi Pedro,

The version you use - 10.0.29 is very old version and no longer supported. By default port 21 should be opened if you were able to connect via Filezilla it means that it’s opened.

We recommend you to install the latest release of SQLBackupAndFTP version 11.7.1 and check if it resolves the issue. You can download it at https://sqlbackupandftp.com/download


#3

Hi

If I use the latest version then the FTP connection ceases to work even in the computer where it was running. Using the exact same settings the new version throws this error message: “[DST-2:1103#550] FTP destination error. > (550).”

The older version I’m using connects successfully in under a second.

So, the situation gets worse if I use the latest version! :stuck_out_tongue:

My settings are the FTP address, username, password and then an active data connection, which is required by the server in question. If I try to use a passive connection the test runs for a long time and then dies with a failure message.

Over to you


#4

Hello,

To investigate this case we need more details, could you please enable the “Advanced Log” reproduce the issue and send logs to our developers. Please find more details at https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

After you enabled the Advanced Log please try to connect to your FTP using “active” and “passive” data connection at the FTP Server Settings window. To investigate this case we need this information to be in the log.