Email notifications not being sent


#1

I have SQLBackupAndFTP ver 12.2.9 running 4 back jobs. The jobs are all running fine except for the email notification. It is generating the following error on all jobs:

10/1/2019 8:08 PM Can’t send email to tnilles@mooreengineeringinc.com: Errors while compiling a Template.
Please try the following to solve the situation:

  • If the problem is about missing/invalid references or multiple defines either try to load
    the missing references manually (in the compiling appdomain!) or
    Specify your references manually by providing your own IReferenceResolver implementation.
    See https://antaris.github.io/RazorEngine/ReferenceResolver.html for details.
    Currently all references have to be available as files!
  • If you get ‘class’ does not contain a definition for ‘member’:
    try another modelType (for example ‘null’ to make the model dynamic).
    NOTE: You CANNOT use typeof(dynamic) to make the model dynamic!
    Or try to use static instead of anonymous/dynamic types.
    More details about the error:
  • error: (145, 3) The type ‘System.Object’ is defined in an assembly that is not referenced. You must add a reference to assembly ‘System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’.
    Temporary fi…

Test emails are sent without issue.


#2

Hi Thomas_Nilles,

Thank you for the details. Please give us some time to check and fix the issue.

Also, could you please try to install the latest release of .NET Framework https://dotnet.microsoft.com/download/dotnet-framework perhaps it will resolve the issue.

Sorry for the inconvenience.