Backup file name changing on scheduled job


#1

Ive go the app set to backup to just database.bak under compress; testing running the job manually works as expected. file at the ftp site is database.bak as expected. run the job again, it overwrites database.bak as expected.

when the job runs from a schedule, the backup file name changes to databasefullcopy.bak. the log of the jobs concur with this change.


#2

Hi Steven Andrews,

Could you please clarify your request?

You can find the option to change the backups file names at the “Compression Settings” window.

Please let us know if you have any other questions.


#3

I have it set as databasename.zip. it’s not a request, it’s a bug. when running from a logged in session it produces a file databasename.bak, when it runs on schedule, it produces instead databasenamefullycopy.bak. this is on the same job.


#4

Hi Steven_Andrews,

Could you please clarify the question?

The issue is that you received a backup with the following name databasenamefullycopy.bak instead of databasename.bak? If yes, then you get this issue because you use a COPY_ONLY option.

SQLBackupAndFTP

Sorry for the inconvenience.