11.1.16 Error on opening


#1

I have installed the software with a view to purchase if successful.
It has not gone well so far!
I have upgraded to 11.1.16 to try to eliminate the problems with the service failing to start after a reboot,
When I open the application, I get a message box.

Value cannot be null.
Parameter name: s

If I click OK to close the message box, Windows Explorer opens displaying the contents of C:\Program Files (x86)\SQLBackupAndFTP

If I create a Backup job, the backup fails.
Job execution error: Value cannot be null.
Parameter name: s. Computer name: “SERVERNAME”

What parameter is it having a problem with, and is there a way of me correcting it?


#2

Thank you for the issue reporting.

To investigate this case we need more details, could you please send us the advanced log. Please click “Tools” > “Advanced log…”, enable log, run the backup job and send log to developers.

You can find more details at https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

Sorry for the inconvenience.


#3

At the moment, I am unable to send you the log. When I click the Send Log to Developers button, I receive the error message “Unrecognized Guid format”.

Am I having problems because your application cannot connect to the internet? Menu options such as Check for Update don’t work. It errors with “There was no endpoint listening at …that could accept the message. This is often caused by an incorrect address or SOAP action.” The server is only used internally, and is behind a proxy server. I can’t see any option to enter proxy settings in the app.


#4

Please click “Open folder” link and send us all files from this folder. To make them private please send them to support@sqlbackupandftp.com


#5

Hello!!! I have the same exact error when doing a fresh installation:

Value cannot be null.
Parameter name: s

If I click OK to close the message box, Windows Explorer opens displaying the contents of C:\Program Files (x86)\SQLBackupAndFTP

I also had the same problem when I tried to send the logs: “Unrecognized Guid format”.

I was able to “open folder” and email the logs to you. I would appreciate any help!!!


#6

Thank you for the details.

Could you please tell us are you able to run the following link https://api.sqlbak.com/Client/Sbf/SbfAccount.svc

Sorry for the inconvenience.


#7

Yes, the link opens a page headed SbfAccount Service. I am able to access the service description, which generates a page of XML. I’m not a developer, so this is all way outside my comfort zone!


#8

I agree with spud!!! I’m able to click on the link too. This is what I see:

SbfAccount Service

You have created a service.

To test this service, you will need to create a client and use it to call the service. You can do this using the svcutil.exe tool from the command line with the following syntax:

svcutil.exe http://api.sqlbak.com/Client/Sbf/SbfAccount.svc?wsdl

You can also access the service description as a single file:

http://api.sqlbak.com/Client/Sbf/SbfAccount.svc?singleWsdl

This will generate a configuration file and a code file that contains the client class. Add the two files to your client application and use the generated client class to call the Service. For example:

C#
class Test
{
static void Main()
{
SbfAccountClient client = new SbfAccountClient();

    // Use the 'client' variable to call operations on the service.

    // Always close the client.
    client.Close();
}

}

Visual Basic
Class Test
Shared Sub Main()
Dim client As SbfAccountClient = New SbfAccountClient()
’ Use the ‘client’ variable to call operations on the service.

    ' Always close the client.
    client.Close()
End Sub

End Class


#9

I have exactly the same problem, we are also behind firewalls so no internet for the sql server.


#10

Thank you for the details. Please give us some time to check this issue.

Sorry for the inconvenience.


#11

If you connect to Internet via proxy you can configure SQLBackupAndFTP application to use your proxy server for Internet connection. To enable connection via a proxy server, you need to create ConnectionSettings file without extension in C:\ProgramData\Pranas.NET\SQLBackupAndFTP\Client folder.
Please remember restart “SQLBackupAndFTP (SQL Server backup)” windows service after updating the configuration to load new settings.

For example:

<?xml version="1.0" encoding="utf-8"?>

< ConnectionSettings xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance” xmlns:xsd=“http://www.w3.org/2001/XMLSchema” xmlns:pranas=“http://www.pranas.net/2012/XMLSchema”>
< WebConnection WebConnectionType=“Proxy”>
< WebProxySettings Address=“127.0.0.1:3128” UseDefaultCredentials=“False” BypassProxyOnLocal=“False”>
< Credentials UserName=“UUU” Password=“PPP” />
< /WebProxySettings>
< /WebConnection>
< /ConnectionSettings>
Where 27.0.0.1:3128 is a proxy address, UUUis a proxy user name and PPP is a password.

To use proxy connection only for all web requests and FTP requests using OPEN command, you should write content like in the example below:

<?xml version="1.0" encoding="utf-16"?>

< ConnectionSettings xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance” xmlns:xsd=“http://www.w3.org/2001/XMLSchema” xmlns:pranas=“http://www.pranas.net/2012/XMLSchema”>
< WebConnection WebConnectionType=“Proxy”>
< WebProxySettings Address=“27.0.0.1:3128” UseDefaultCredentials=“False” BypassProxyOnLocal=“False”>
< Credentials UserName=“UUU” Password=“PPP” />
< /WebProxySettings>
< /WebConnection>
< FtpConnection FtpConnectionType=“Proxy”>
< FtpProxySettings AuthenticationMethod=“Basic” BypassProxyOnLocal=“False” Host=“27.0.0.1” Port=“2121” ProxyType=“FtpOpen”>
< Credentials UserName=“UUU” Password=“PPP” />
< /FtpProxySettings>
< /FtpConnection>
< /ConnectionSettings>

Please find the files with a simple configuration and full configuration specifications by the following link https://www.dropbox.com/sh/7kkoi1b1kyoi85a/AAD6Z6wzIBKw2YDBHZXUJ8_ua?dl=0


#12

Thank you for the information, Alexander. Is there an option or an older version I can use that does not need to connect to the internet? I would like to use the backup utility behind a firewall and I will never connect to the internet to do backups. For security reasons I would prefer that there isn’t a connection outside of my firewall. Any ideas?


#13

This issue has been fixed in the latest version of SQLBackupAndFTP version 11.1.18. Could you please uninstall your current version and install the latest one. You can download it at https://sqlbackupandftp.com/download

If you still have this issue with the latest version please save the NLog.config file into the application folder C:\Program Files (x86)\SQLBackupAndFTP, restart “SQLBackupAndFTP (SQL Server backup)” Windows service, run the backup job and send us all log files from C:\Log\SBF folder after this issue happens again.

To download Nlog.config file please follow this link https://www.dropbox.com/s/xw380o7t973j5yc/NLog.config?dl=0

To make it private please send to support@sqlbackupandftp.com


#14

Hello I am having the same issue with version 12.2.3. We are connecting using SSH tunnel and the MySQL server is setup as defaults so the main server name should be localhost however we get the same error message:

Localhost test failed value cannot be null parameter name:source


#15

I have managed to get round it by updating to the latest version and now I get a time out error on one of my databases? Where can increase this time as I cannot find it, please attach screenshots. Thank you.


#16

Hi guys,

To investigate this case we need more details. Could you please enable the advanced log with “Trace” level, reproduce the issue and send logs to our dev team. Here are more details on how to do it https://sqlbackupandftp.com/blog/how-to-send-log-to-developers

Note! With the “Trace” level, a log can contain your passwords. Before sending a log to dev team please open it using any text editor and remove the information you prefer to keep in secret. You can find them by clicking the “Open folder” link at the “Advanced Log” window (“Tools” > “Advanced Log…”).

Please let us know if the logs will be sent, also please provide us with your application id (“Help” > “About”).

Sorry for the inconvenience.


#17

Issue has now been resolved. We had to restart all services on the older version which we was licensed for and re-import the old job that we had created. For some reason with a fresh install not all services where operating correctly and thus we could not connect to the MYSQL server through our SSH tunnel. Thank you for your help.


#18

Hello,

Good news! Thank you for your reply.

Please feel free to contact us on any issues or concerns.