Remote Backup failed on version 11.1.4


I am using SqlBackupAndFTP for many years without single problem, but version 11 is giving me severe headaches.
I managed to set up backup of my local databases and my Azure databases but i can’t set up backup for one of my remote MS SQL databases. I am getting next error message:

Failed to backup “kataloglagera” database with “Full” backup type: Cannot open backup device ‘C:\Temp\Pranas.NET\SQLBackupAndFTP\backup\kataloglagera201707040712.bak’. Operating system error 3(error not found).
BACKUP DATABASE is terminating abnormally.

I red some forums and all offered solutions are related to folder rights, but this folder is used by other backup jobs too without any problem so I am totally confused.

Please help me to solve this as I have to decide either to buy license for new version or not.


Sorry, but you can not perform remote backups using SQLBackupAndFTP version 11. [Correction: as of Feb 2018 remote backups are included again]

We recommend you to install SQLBackupAndFTP version 11 on the same computer where SQL Server is installed.

Please find more details at

I’m assuming that this is just a licensing grab. I’m very disappointed that this feature has been removed. I only discovered this after upgrading to 11. I would have stayed on 10 had I known. I’m now in the process of looking at other software as a result.

The remote backup in the previous versions was in permanent Beta and was not a reliable method of backup, that’s why we exclude this feature from the new version.

Sorry for the inconvenience.

I understand that it was in permanent beta, but it worked great in most situations. Also, the weblog feature has been removed, which worked great. I know that you are in business to make money, but increasing the price and removing features for customers is really frustrating. I would have happily recommended this product in the past, but I don’t know that I can anymore. Sorry.

Yes, we had the remote backup feature that made backups using completely different from the standard backup method - scripting. Despite warnings that it is in unsupported permanent Beta, people have used it and too many of them got into the situation when they couldn’t reliably restore it when they needed. We have invested endless hours trying to improve the process and support such customers, but it was still very unreliable. This is not the right way to do the backups and we do not want it in our product any longer. If you prefer v10 - we have no questions asked refund policy. We will happily return your money and you can continue using v10.
As far as the weblog - we are bringing it back - see the discussion here: Weblog Availability

I’m disappointed but I understand. Thanks for the detailed explanation.

OK, change of plans. We were unhappy with our own implementation of remote SQL backups - that is why we’ve dropped it from v11. However now we are adding remote backups implementation based on SMO objects and it works great! We will start a limited release next week and if everything goes smoothly - it will be available to everyone in a week or two.

Please do inform when it release the feature of remote backup/restore.


Still testing. Should be out next week.

OK. Remote backup is rolling out automatically in v11.4.2. If you don’t have it updated yet, just wait a day or two. To do a remote backup, on “Connect” window select “Remote SQL Server” in “Server Type” field. We will email our user an official notification later this week.