Job Execution error

Hi jankowicz,

We are really sorry about the inconvenience and thanks for the bug reports. Currently, we are working on the new release where this issue should be fixed.

Sorry for the delay and for the inconvenience.

Hi jankowicz,

Sorry for the delay. The new version with the fix is available at the “Download” page. Could you please install it and check if it works?

Sorry for the inconvenience.

Hi Alexander,

we’ve installed v12.3.3 a few days ago but unfortunately it did not fix the issue. Today we’ve find out why. Timeouts.xml file which we’ve been asked to download from Dropbox a few weeks ago (link to this file is still valid and can be found a few posts above) has different schema than XML described here So, I assume spp couldn’t read it (parse error) and has always set up default values and thats why we always get timeout error after 00:03:00 (180 sec). Update process from 12.2.x to 12.3.3 did not replace wrong file with the correct one. Don’t know how to comment it especially that I’ve pasted incorrect Timeouts.xml a few posts above with info that app did not load custom timeouts and instead still uses the defauld ones and… nobody noticed.

We’ve replaced incorrect Timeouts.xml today taking example from your Wiki and increasing timeouts for NetPipe as needed. I’ll let you know tomorrow if it helped.

Dear jankowicz,

Sorry for the inconvenience.

Sure, please feel free to contact us on any issues or concerns.

Hi Alexander,

Timeouts helped. App is finally able to copy backup from the server to disk destinaiton on local network.

Thank you.

Hi Alexander,

Not quite as successful here, After applying the timeouts.xml from the wiki entry, I’m still getting time timeout messages. I’ve double the timeouts to 6 minutes, but I still get regular 3 minutes timeouts according to the error log. It seems to happen when deleting backups that are older and set for cleanup.

Thanks Richard

Hi Richard_Hamblin,

check Timeouts.xml schema twice. I downloaded this file first time from Dropbox as Alexander asked me and it did not work. Found out that XML schema in Wiki differs from schema from Dropbox. Use schama from Wiki and app v12.3.3. App update did not override Timeouts.xml to valid one - maybe a bug or maybe intentional to preserve your configuration. But the fact is that XML schema has changed since they introduced Timeouts.xml for the first time.

Hi jankowicz,

I’ve recreated the timeouts.xml from the Wiki page and I’ll see how it gets on overnight.

Thanks for the info

Hi guys!

Thank you for the details, also you can find more information about how to increase timeout values at


it seems that this it not the end :frowning:

Got v12.3.4 and it worked as a charm since we’ve changed Timeouts.xml few days ago (valid xml schema and long timeouts). But now 2 times in a row it failed from the same reason as previously - timeout error during upload:

Uploading local “xxx_FileStore202002060900.7z” to remote “xxx_FileStore202002060900.7z” in folder “E:\xxx\Backups\xxx_FileStore”

Error, as previously says it is 3 minute tmimeout:

ERROR: Destination error: This request operation sent to net.pipe://localhost/pranasnet/net/sbf/Trace/Net.pranasnet.sbf.Trace did not receive a reply within the configured timeout (00:03:00).

But we don’t have any 3 minute timeout in the config:

I would think this time it was our fault… if it wasn’t telling me about 00:03:00 timeout.

What are we doing wrong? Please help.

Hi Alexander,
just to confirm, we still have the same issues as before with the 3 minute timeout message. We too have changed all of the values in the xml file way past 3 minutes but are still getting the error message. It is always on the upload. This location is a local disk. Hope this information helps in resolving this issue.
Thanks in advance

Hi guys,

Please give us some time to check the issue.

Sorry for the inconvenience.

Hello guys,

We are still working on this issue, and we need more details. Could you please contact our support team directly and provide us with more details. Please:

  1. Install the latest Alpha edition
  2. Send us your backup job configuration “Tools” > “Configuration Manager…” > “Export”.
  3. Reproduce the issue and send us the advanced log
  4. Tell us what OS and what version of .NET Framework do you use?

Sorry for the inconvenience.

Hi Alexander,

we’ve installed v12.3.8.2 but unfortunately issue is still there, nothing has changed.

  • Windows Server 2016 + recent updates,
  • .NET Framework 4.6.2.
  • advanced logs - sent using “Sent logs to developers” at ~8:00AM UTC, 25 of February (I’m writing this post from a different account than the owner of our licences, hope you will find logs)
  • job configuration - it seems that exported config file contains sensitive data. I cannot send it to you, I’m sorry. What can we do instead?

Best regards

Hi jankowicz,

Appreciate your response with the detailed information!

We have added some changes to SQLBackupAndFTP. Could you please install the following version and check if it works for you?

Sorry for the inconvenience.

Hi jankowicz,

Have you had a chance to test the version we sent? Could you please let us know if it works for you? If the issue is resolved, we’ll add the changes to the stable version of SQLBackupAndFTP.

Thank you, and sorry for the inconvenience.

Hi Alexander,

we’ve installed v12.3.10. First 2 backups are successful but we’d like to wait a few days more to be sure.

Hi jankowicz,

Thank you for your reply.

Sure, please let us know if there is anything else we can help you with.

Hi Aleksander,

two weeks after installing v12.3.10 I’m happy to inform you that all signs in heaven and on earth show that issue is fixed.
Initial conditions has changed since we’ve started few months ago (backup is split into smaller files) but database over 190GB is now sucessfully copied on local drive after backup. Thank you.

Could you uncover the secter a little bit and tell what we’ve been fighting for so long?

Hi jankowicz,

Thank you for your reply. That’s great!

The issue was in the .net RX library that we used to trace download speed in a job log. For some reason, that library loaded the application during heavy work. That issue happens in a very small percentage of users; we decided to disable that option by default. If it is needed, you can enable it at the application’s settings Tools > Settings > Job Log Settings > Trace upload speed.

1 Like