Command line backups not working

v11.1.13 on Windows Server 2012 R2

I’m trying to run a backup from the command line (as per but nothing happens. No event log, no feedback, nothing at all.

I originally tried using Windows Task Scheduler (which reports Last Run Result 0x0) and then tried from a command line.

The backup job runs fine from the GUI.

Any ideas what might be going wrong here?


Hi Simon,

Thank you, we’ll add more information when starting a backup job.

Thank you. Do you have any idea why the command line isn’t doing the backups? Are there any known issues with launching backups from the command line?

We have tested it and everything works properly.

Probably, you may need to run it as administrator.

Also, please clarify do you use Windows Authentication or SQL Server Authentication to connect to SQL Server?

Hi Alexander.

I’ve tried running it from an Administrator elevated command prompt but I still have the same result - no backup and no feedback as to why.

I’m using SQL authentication. The backup job runs fine when using the inbuilt SQLBackupAndFtp scheduler.


Thank you, we’ll check it.


Please install the latest version of SQLBackupAndFTP 11.1.16. It writes into console all backup log records or error messages. Also, you can check Windows Event Log for messages related to job start/stop.


Hi Alexey,

The Windows Application log messages for scheduled backups or those run from the GUI are working fine.

However, I’m still getting nothing at all from the command line backup. Nothing in the console and nothing the Application log.


Could you please tell us more details about this issue. What arguments do you use?

I think I’ve fixed it - one of the parameters was using a different case. Having tested I can now see that all parameters are case sensitive.

Just a thought, but you might want to include some feedback to the console if the CLI command is run with incorrect or missing parameters.


Thanks for the feedback Simon, we’ll consider your suggestion.

Is there a way to add “With copy_only” to the backup so that a Full Backup does not change the Differential Attributes. Can this be done in the GUI under custom scripts or can it be done with the Command Line.

Thank you

Hi Joseph,

Yes, you can add “Copy_Only” option to backup from a command line, please find more details at How to run SqlBackupAndFtp v11 from a command line | SQLBackupAndFTP's blog

Also, you can find this option at the “Backup option” settings.